Execution php avec Crontab chez Ikoula (unix)

Résolu
Bonjour,

Je possède un compte chez ikoula qui me permet de partager un serveur et développer mon site web.
L'hébergeur (ikoula) propose de planifier des taches via crontab.
La partie de planification (H, mn, JOUR, MOI, ...) ne pose jusqu'alors aucun probleme. Malheureusement au niveau de la commande à taper c'est autre chose :
Mon but est d'ouvrir un fichier php pour en executer le contenu et là apparait différents problemes (voici les 3 erreurs auxquelles je ne m'attendais en aucun cas) :

Commande:
php /httpdocs/admin/algorythmeglobal.php

Fichier php (NOMDUSERV/httpdocs/admin/algorythmeglobal.php)
#!/usr/bin/php
<?php
//PHP FONCTIONNEL
?>

Erreur:
-: php: command not found

//////////////////////////

Commande:
/httpdocs/admin/algorythmeglobal.php

Fichier php (NOMDUSERV/httpdocs/admin/algorythmeglobal.php)
#!/usr/bin/php
<?php
//PHP FONCTIONNEL
?>

Erreur:
-: /httpdocs/admin/algorythmeglobal.php: /usr/bin/php: bad interpreter: No such file or directory

//////////////////////////

Commande:
/httpdocs/admin/algorythmeglobal.php

Fichier php (NOMDUSERV/httpdocs/admin/algorythmeglobal.php)
#!/usr/local/bin/php
<?php
//PHP FONCTIONNEL
?>

Erreur:
-: /httpdocs/admin/algorythmeglobal.php: /usr/local/bin/php: bad interpreter: No such file or directory

L'écriture du fichier php est en ASCII, Format Unix.
Merci à tout ceux qui auraient une expérience sur ce sujet et pourrait m'apporter leur précieuse aide.

6 réponses

  1. Finalement j'ai ma réponse: C'est l'abonnement!
    Merci à tout les deux.
    1

    1. Commande:
      php /httpdocs/admin/algorythmeglobal.php
      Erreur:
      -: php: command not found


      Tu as installer php-cli sur ton serveur ?
      Pour tester, dans la console :
      php -v
      
      0
      1. Lorsque tu parles de console, tu parles de celle que l'on a lors d'une connexion ssh? (connexion qu'il m'est impossible de mettre en place du fait que mon serveur n'est pas dédié)
        Mais le cli ne semble pas pris en charge (ou alors je n'ai pas accès aux dossiers dans lesquelles il est installé).
        Par contre le CGI, FastCGI et le PHP ( ... ) sont pris en charge.
        Me serais je trompé lors de l'écriture de mes commandes pour que celles-ci soient correctement lus avec le CGI?
        0
        1. Si tu ne peux pas utiliser php-cli, il y a des solutions alternatives :
          https://forums.phplist.com/viewtopic.php?p=26351

          connexion qu'il m'est impossible de mettre en place du fait que mon serveur n'est pas dédié
          Pour info, a a des mutu ou tu peux le faire ça dépend de ton hébergeur.
          0
          1. Pourquoi ne passe tu pas tous simplement par la commande "wget".

            Après tu chercher "/usr/local/bin/php" est tu sur que les bin de PHP sont bien dans ce dossier ?
            0
            1. Merci pour votre aide, mais il semblerait que tout provienne de l'hébergeur Ikoula qui limite un maximum les possibilités de l'utilisateur avec le forfait que j'ai pris.
              La phplist ne semble pas être activé (non autorisé?) j'ai en effet essayé curl-s, GET, lynx -dump, wget -q -O ; mais c'est toujours la même histoire: command not found
              Je me demande s'il ne me contraignent pas aux commandes basiques afin que le serveur ne soit pas -sur-utilisé.
              Merci, mais je pense que le mieux à faire serait d'envoyer un message au service client de manière à en apprendre plus a propos de leur "Tâches planifiées". J'essaie de vous tenir au courant.
              0