Problème de résolution de noms sur débian [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
vendredi 5 août 2011
Statut
Membre
Dernière intervention
8 août 2011
-
Messages postés
29318
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
13 octobre 2020
-
Bonjour,

J'ai un problème sur un serveur virtuel Linux debian : je ne peux pas résoudre les noms.
Je ping bien les IP, mais je peux pas pinguer de noms.
J'ai bien les IP des 2 serveurs DNS dans le resolv.conf (les serveurs DNS sont fonctionnels), ils sont aussi renseignés dans le etc/network/interfaces (dns-nameservers)
Je redémarre le serveur -> pas d'amélioration
ifup/ifdown -> pas d'amélioration

Y a t-il un paramètre a activer pour utiliser le client dns que je n'ai pas vu (comme un daemon peut etre)

Merci d'avance de m'aider je suis bien embêté.

5 réponses

Messages postés
1364
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 juin 2013
231
A priori, tu n'as pas de problème de routage, sans quoi tu ne pourrais pas pinguer les DNS depuis ton serveur Debian.

A ) Tu pingues les IP des DNS depuis la Debian et tu pingues les IP de la Debian depuis les DNS ?
B ) Ton serveur Debian, est-il renseigné dans les entrées hosts des serveurs DNS ?

Tiens, un peu de lecture
http://doc.ubuntu-fr.org/dns
http://doc.ubuntu-fr.org/configuration_serveur_dns_dhcp
http://doc.ubuntu-fr.org/bind9
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
1364
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 juin 2013
231
Tu as un problème de résolution au niveau du nom des serveurs, ou bien noms + nom de domaine ?
Messages postés
5
Date d'inscription
vendredi 5 août 2011
Statut
Membre
Dernière intervention
8 août 2011

nom et nom de domaine
Les noms de serveur DNS sont renseignés, mais il n'arrive pas a leur demander de résolution.
Et ces serveurs DNS fonctionnent bien avec d'autres seveurs à coté.
Mon problème povient donc de la débian qui n'arrive pas à résoudre.
Ce serveur est en fait un relaymail sous postfix, sans résolution tous les mails transitant sont bloqués car il ne peut pas savoir ou les deposer.
Messages postés
29318
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
13 octobre 2020
6 941
Peux-tu nous reporter le résultat des commandes suivantes :

/sbin/route -n
cat /etc/resolv.conf
cat /etc/hosts
cat /etc/network/interfaces
ping -c2 ip_du_premier_dns
ping -c2 ip_du_second_dns
nslookup www.google.fr
ping -c2 www.google.fr


Tu peux d'ores et déjà commencer à lire ceci si tu ne t'y connais pas trop en administration réseau sous debian :
http://www.mistra.fr/tutoriel-linux-configurer-le-reseau.html

Pour le moment je ne suis pas persuadé qu'installer bind9 soit vraiment nécessaire. On peut installer un serveur DNS pour améliorer les performances de résolution DNS ou pour éviter les latences de résolution engendrée sur certaines livebox mais sinon, les DNS de ton FAI devraient faire l'affaire.

De plus pour que bind9 soit exploité il faudra changer tes DNS dans /etc/resolv.conf par 127.0.0.1. Si cette IP est configurée automatiquement par DHCP, il faudra pour cela ajouter dans /etc/dhcp/dhclient.conf la ligne :

supersede domain-name-servers 127.0.0.1;


... car sinon, à chaque redémarrage du service réseau, ton fichier /etc/resolv.conf sera écrasé et référencera le serveur DNS indiqué par ton serveur DHCP.

Bonne chance
Messages postés
5
Date d'inscription
vendredi 5 août 2011
Statut
Membre
Dernière intervention
8 août 2011

Dans resolv.conf il y a 2 ip des dns du fai ( nameserver 194.149.160.1 et nameserver 194.149.160.1) et mon linux n'a pas l'air de travailller avec eux puisqu'il ne résout pas les noms :
Ping www.google.fr = pas de reponse
Ping l'ip de google résolue (74.125.39.105) = réponse OK.

Mon serveur débian est connecté avec une ip fixe et externe. Il est hébergé cher IIliad a coté de 4 autres serveur qui ont la meme config DNS (FAI 194.149.160.1 et 9 )et qui résolvent bien.
Par contre ces serveur dns FAI ne répondent pas au ping avec tout mes serveurs( ce qui, je pense, doit etre normal)

Pour nslookup je n'ai pas le pakage correspondant et je ne peux pas le mettre car pas de résolution.
Messages postés
5
Date d'inscription
vendredi 5 août 2011
Statut
Membre
Dernière intervention
8 août 2011

J'ajoute que lorsque je vire le contenu du resolv.conf (a savoir "nameserver 194.149.160.1 ; nameserver 194.149.160.1") et que je fais : ping www.google.fr j'obtient : "ping : unknown host www.google.fr".
Quand le résolv.conf est renseigné comme c'était et que je fais la meme commande ( ping www.google.fr) il n'y a rien d'affiché.
Messages postés
5
Date d'inscription
vendredi 5 août 2011
Statut
Membre
Dernière intervention
8 août 2011

Merci pour vos réponses, le problème est résolu

Les DNS resolvers ont changé, mon hébergeur a juste oublié de nous prévenir.
Il va recevoir un mail ou un appel bien gratiné de mon boss
Messages postés
29318
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
13 octobre 2020
6 941
Ok, merci de ces précisions :-)