[Samba] Problème de droits sur dossiers [Résolu/Fermé]

Signaler
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
-
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
-
Bonjour à tous,

Voilà j'ai un problème assez particulier avec mon réseau familial.
Dans ce problème il y a 3 machines :
- machine1 est le serveur Samba (Ubuntu 6.06)
- machine2 est un client Samba (Mandrake 10.1)
- machine3 est un autre client Samba (Win XP)

Depuis la machine1 j'ai partagé un répertoire /home/videos, sous le nom "videos". J'ai autorisé le parcours du dossier et interdit l'écriture.
Depuis la machine2 j'ai monté le dossier \\machine1\videos sur /home/user/mnt/videos, avec l'uid de mon utilisateur normal et les masques fichiers 644 et dossiers 755. Je suis donc sensé pouvoir naviguer dans les dossiers contenus dans /home/user/mnt/videos avec mon utilisateur normal.

Le problème :
Depuis la machine3 (sous XP donc), je navigue effectivement correctement dans les dossiers sans soucis.
Depuis la machine2 (Mandrake), les dossiers situés à l'intérieur de /home/user/mnt/videos sont notés comme appartenant à root et ont un masque fichier de 750 et dossiers 550. C'est pas normal !

Pour ceux qui se poseraient la question du pourquoi j'ai mis Samba pour partager un répertoire entre 2 machines Linux, c'est parce que la machine1 est en dual-boot et je conserve ainsi les mêmes paramètres entre Windows et Linux. Transparence !

Quelqu'un aurait-il une idée du problème en question ??

5 réponses


heu je sais que quand on partage le dossier /home seulement l'utilisateur du /home y a accés
peut etre que ca vient de la
mais alors pourquoi sous xp ca passe et pas sous mandrake !
essaye de créer le meme utilisateur sous mandrake que celui qui partage le home sous ubuntu

si y'en a qui ont d'autres idée qu'ils n'hésites pas lol !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
2
En fait j'ai "arrondi" le contexte : le répertoire ne se trouve pas dans /home mais dans un autre dossier de l'arborescence, accessible en lecture et exécution.
Donc ça ne peut pas être ça... mais merci quand même d'avoir esssayé !

Ce que je trouve très bizarre ce sont les droits appliqués aux sous-dossiers du répertoire monté, et l'utilisateur propriétaire. J'ai fait ça avec LinNeighborHood pour ceux qui connaissent, et y'a aucun moyen de se planter au moment du montage sur l'UID, le GID et les masques à mettre : tout est graphique !

Une autre idée ??
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 857 >
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009

Salut,

Une autre idée ??
Oui, affiche ton fichier "/etc/samba/smb.conf", on devrait y voir plus clair qu'au travers d'une "GUI ";-))
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
2 >
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020

Ok ok je savais que j'allais passer par là... :o)

Voilà donc le smb.conf de ma machine1 (Serveur Samba sous Ubuntu) :

[global]
workgroup = WORKGROUP
server string = %h server (Samba, Ubuntu)
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
panic action = /usr/share/samba/panic-action %d
encrypt passwords = true
passdb backend = tdbsam
invalid users = root
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .

[VIDEOS]
read list = utilisateur
public = yes
user = utilisateur
path = /media/hda5/videos
force directory mode = 755
available = yes
browseable = yes
writable = no


Ces config ont été faites par le module de config de Gnome (Système - Administration - Répertoires partagés).
C'est plus clair ? :o)
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 857
Re-

Ton "utilisateur" Mandriva fait-il parti de la liste de "utilisateur" ?
Et quand est-il des droits sur le montage de ta partition dans le "fstab" ?
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
2
Qu'entends tu par :
Ton "utilisateur" Mandriva fait-il parti de la liste de "utilisateur" ? ?

Pour le montage de la partition je ne vois pas où serait le problème. La partition /media/hda5 est montable en lecture seule par l'utilisateur normal.

Et attends, le pire c'est que quand sur la machine2 (Mandrake) je me connecte dans le terminal par :
smbclient \\\\MACHINE1\\VIDEOS -U utilisateur

et que je rentre le code je peux naviguer sans problème dans tous les dossiers ! Y'a un truc qui tourne vraiment pas rond !

Le problème serait dans smbmount peut-être ??

Correction : dans le dossier monté les fichiers ont les droits 770 et 550 pour les dossiers, et le proprio est root
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 857
Qu'entends tu par :
Ton "utilisateur" Mandriva fait-il parti de la liste de "utilisateur" ? ?

Désolé, j'ai confondu :
read list = utilisateur
avec :
read list = @utilisateur
Notion de groupe.. oups ;-)

Le problème serait dans smbmount peut-être ??
On n'est pas devin ;-)
Affiches-nous en les propriétés alors. Merci.
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
2
Autre précision, quand je passe la machine1 sous Win2k les partages sont les mêmes. Je lance donc la même commande de montage sur la machine2 et là tout fonctionne !
Les fichiers et dossiers ont les bons droits et le proprio est, cette fois, l'utilisateur normale de la machine2.

Je-ne-com-prends-pas !
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
2
read list = utilisateur
avec :
read list = @utilisateur
Notion de groupe.. oups ;-)

Ok pour le groupe je comprends mieux.

On n'est pas devin ;-)
Affiches-nous en les propriétés alors. Merci.

Bon d'accord vous êtes pas devin......certes......mais vous devriez ! :o)
Blague à part, que veux tu que je te dise à propos des "propriétés de smbmount" ??
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 857
SMBMOUNT(8)                                                        SMBMOUNT(8)

NOM
       smbmount - monte un système de fichiers SMB

SYNOPSIS
       smbmount service point_de_montage [ -o options ]

DESCRIPTION
       smbmount monte un système de fichiers Linux SMB.  Il est souvent appelé
       par mount.smbfs de la commande mount(8) lorsque l'option  « -t  smbfs »
       est utilisée.  Cette option n'est supportée que sous Linux et le kernel
       doit supporter les systèmes de fichiers smbfs.

       Les options de smbmount sont spécifiées comme  une  liste  de  doublets
       clef=valeur  séparées  par des virgules. 
S'il y a problème c'est sûrement à ce niveau, non ?
Messages postés
65
Date d'inscription
mardi 8 mars 2005
Statut
Membre
Dernière intervention
26 avril 2009
2 >
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020

Merci de te patience !

J'ai essayé de monter le dossier depuis la ligne de commande (sans passer par LinNeighborHood) et le problème reste le même. Alors que, comme toujours, quand je navigue dans les partages Samba par smbclient (par exemple), il n'y a aucun problème.

Pour tester, j'ai lancé le LiveCD d'Ubuntu 6.06, installé smbmount/smbmnt et j'ai pu monter le dossier dans un répertoire similaire.....et là tout fonctionne ! Je pense finalement que c'est ma Mandrake qui déconne. Je vais passer à Ubuntu (ou Kubuntu) sur celui là aussi, ça me permettra d'utiliser un vrai logiciel libre :o)

Merci encore jipicy !