.htaccess non detecté en local (easyphp 5.3)

Résolu/Fermé
Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 - Modifié par Aktayen le 23/03/2011 à 09:49
Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 - 23 mars 2011 à 11:57
Bonjour à toute la communauté,

Je sais que ce sujet a été traité plusieurs fois, mais j'ai tout testé et rien n'a résolu mon problème.

Depuis hier j'essaye d'activer les .htaccess en local sur mon pc sans succès. Voici mon code dans le .htaccess.

Options +FollowSymlinks     
RewriteEngine on     
RewriteRule ^inconnu\.html$  /test/test.html [L]


J'ai remplacé tout les "AllowOverride none" par "AllowOverride All" ce qui ne change rien.

Mes fichiers test.html et .htaccess se trouve dans le dossier "test" à la source.
l'url que je test est la suivante :
http://127.0.0.1/test/inconnu.html

Ce qui m'affiche l'erreur 404.

Est ce que je dois changer autres choses dans le httpd.conf?

Je précise que si je charge le fichier sur mon ftp, ça marche, c'est juste le local qui pose problème.

Merci d'avance,









7 réponses

Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 18
23 mars 2011 à 09:50
Un petit up..
0
boly38 Messages postés 267 Date d'inscription mercredi 23 février 2011 Statut Membre Dernière intervention 29 septembre 2016 80
Modifié par boly38 le 23/03/2011 à 10:13
Ici peut être qu'il est appliqué et qu'il te réécrit l'url comme ceci ? :

http://127.0.0.1/test/inconnu.html
=> http://127.0.0.1/test/test/test.html

tente d'ajouter le html correspondant
0
Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 18
23 mars 2011 à 10:19
Non j'ai essayé et ça marche pas.

Ce qui est énervant c'est que ça marche une fois en ligne.. mais bon c'est chiant de transferer sur le ftp pour tester..
0
boly38 Messages postés 267 Date d'inscription mercredi 23 février 2011 Statut Membre Dernière intervention 29 septembre 2016 80
Modifié par boly38 le 23/03/2011 à 10:30
le module apache rewrite est-il bien chargé ?
a2enmod rewrite 


heu avec easyphp ce doit être directement dans les menus :)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 18
23 mars 2011 à 10:35
je suis censé le trouver où cette ligne?

Dans les modules d'apache j'ai mod_rewrite.so de présent.
0
boly38 Messages postés 267 Date d'inscription mercredi 23 février 2011 Statut Membre Dernière intervention 29 septembre 2016 80
23 mars 2011 à 10:40
ok
après une petite recherche ( src: https://www.webrankinfo.com/forum/t/resolu-url-rewriting-fonctionne-pas-sous-easyphp.72995/ ) a priori le rewrite d'EasyPhp est par défaut paramétré pour fonctionner avec /www ;
tente d'ajouter la ligne suivante :
RewriteBase / 
0
Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 18
23 mars 2011 à 10:50
Options +FollowSymlinks
RewriteEngine on
RewriteBase / 
RewriteRule ^inconnu\.html$  /test/test.html [L]


J'ai ça mtn et ça marche toujours pas.. Et j'avais fais tout ce qui dise dans le topic.
0
boly38 Messages postés 267 Date d'inscription mercredi 23 février 2011 Statut Membre Dernière intervention 29 septembre 2016 80
Modifié par boly38 le 23/03/2011 à 10:58
2 petites questions
est-ce que certains dossiers utilisés comme "test" ici est un lien symbolique ? si oui essaie sans

pourquoi mettre l'Options +FollowSymlinks ici et non dans la déclaration "Directory" correspondante d'apache ?
0
Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 18
23 mars 2011 à 11:02
la structure de mon dossier est le suivant
racine 
   dossier test
       test.html
       .htaccess

il y a rien d'autre.

Après j'ai mis + Follow car j'ai suivi ce tutoriel : https://www.webrankinfo.com/dossiers/techniques/tutoriel-url-rewriting .
Et j'avoue que je ne sais pas à quoi ça correspond.
0
boly38 Messages postés 267 Date d'inscription mercredi 23 février 2011 Statut Membre Dernière intervention 29 septembre 2016 80
23 mars 2011 à 11:13
une dernière idée (après je sèche :p) : ce qui me gêne depuis le début c'est que .htaccess ne soit pas à la racine : ce fichier est-il bien dans le dossier paramétré sous apache : si c'est racine, alors le mettre sous racine..
0
boly38 Messages postés 267 Date d'inscription mercredi 23 février 2011 Statut Membre Dernière intervention 29 septembre 2016 80
Modifié par boly38 le 23/03/2011 à 11:53
Peut être une histoire d'encodage du fichier ".htaccess" lui même UTF8 => ANSI
cf. https://openclassrooms.com/forum/sujet/easyphp-et-htaccess-53768

un éditeur comme PSPad permet de faire çà (menu Format)
0
Aktayen Messages postés 189 Date d'inscription dimanche 31 mai 2009 Statut Membre Dernière intervention 17 décembre 2015 18
23 mars 2011 à 11:57
Bon bah j'ai fini par trouvé et je suis assez dégouté.
D'un peu partout j'ai vu qu'il fallait modifier le httpd.conf dans apache..
J'ai réussi à trouver 3 fois ce fichier dans apache et rien ne changé lors de la modification.

Enfaite il faut aller dans le fichier "conf_files" et modifier le httpd.conf qui est dedans.. pas les autres..

Ca doit dépendre de la version d'easyphp..

En tout cas, un grand merci boly pour ton aide..
0