Fenetre alert() javascript fantôme [Résolu/Fermé]

Signaler
-
 cathy -
Bonjour,

J'ai une fenêtre javascript de message d'alerte qui ne cesse d'apparaitre alors que plus aucun script n'existe dans mes pages html, quel est ce mystère ? en plus j'avais voulu insérer ce message d'alerte pour inciter à s'inscrire à la newsletter sur UNE SEULE PAGE de mon site (la plus visitée) pour finir je l'ai enlevé de cette page, mais elle continue à s'afficher et en page d'accueil, et sur les autres pages du site, c'est embêtant car je ne sais pas du tout comment retirer cela ne voyant aucun script nulle part sur mes pages, c'est comme une fenêtre d'alerte "fantôme" un résiduel de quelque chose, c'est vraiment très étrange et j'avoue que je sèche, si quelqu'un pouvait m'aider ? je lui en serais extrêmement reconnaissante, car cette alerte agace le visiteur et ce n'est pas très bon pour mon site ! mon éditeur html est Namo Web Editor 6.

Merci encore de votre aide,
Cathy


7 réponses


salut,
ça peux être une infection si tu es sure de n'avoir aucun script dans tes pages essai de désactiver javascript dans les options du navigateur et chaque fois tu regardes le code source de ta page lorsqu'elle est chargée s'il y'a un script qui s'est rajouté
Bonjour eone2,
merci pour la réponse, je ne vois pas quoi désactiver dans les options internet ? tu me dis désactive javascript je ne vois pas où ? j'ai IE 8. Une injection ? c'est quoi exactement ? j'ai déjà regardé le code source de mes pages il n'y a aucun script qui s'est inséré mais je n'ai pas fait ce que tu me demandes en options internet mais je ne vois pas quelle case cocher pour désactiver javascript !? merci de m'aider, on va y arriver ! c'est étrange tout de même cette histoire ! qu'est que j'ai fait comme bêtise pour que ça fasse ça ?

Encore merci de ton aide eone2, j"attends ta réponse,

ok Bon je suis plutôt firefox mais je crois que sur IE on va sur options securité > puis securité (internet) > puis personnaliser le niveau (bouton tout en bas ) > puis tu vas sur script asp et tu coches le bouton désactiver.
je parlais d'une "infection", certains virus peuvent mettre du code dans tes pages mais le plus répandu est l'insertion d'une iframe dans la page html.
Bonjour eone2,

Je ne pense pas que ce soit un virus, c'est ma propre fenêtre en alert() java, avec mon texte à moi ce n'est pas une alerte quelconque, c'est moi qui l'ai fait seulement je ne parviens pas à l"enlever, et j'ai fait ce que tu as dis décoché script asp, ça ne change rien !? enfin si le message ne s'affiche plus mais vu en affichage source ça ne change rien (vu qu'il n'y a pas ce script dans ma page html) je vais devenir chèvre il y a pas de mystère ! il y a forcément quelque chose à faire ... ça ne vient pas de nulle part quand même ? j'ai testé mes pages sur un autre hébergeur (free) où j'ai d'autres sites, là c'est online.net, ça ne le fait pas l'alerte bizarre non ? ce qui est logique vu que je n'ai pas ce script sur les pages ... c'est un truc qui doit se mettre automatiquement, mais je ne sais plus ce que j'ai bidouiller sous namo 6 ! aie aie aie ! ça me travaille cette histoire, merci eaone2 pour ton aide ... quelqu'un d'autre aurait une idée ? merci

cathy
j'ai trouvé ! j'avais le script dans une frame de ma page html ! mais aucun idée comment ça s'est retrouvé là-dedans ! pas normal mais bon le principal c'est que j'ai pu trouvé et supprimé ! il y a de ces trucs des fois ? merci encore à toi eone2,

Cathy
ok, si c'est ton code javascript qui s'exécute oui effectivement ce n'est pas un virus mais tu n'as pas compris mon raisonnement. Je t'ai dit de décocher script asp pour pouvoir regarder le code source directement sur le navigateur car lui aussi peut rajouter un truc sur tes pages, c'est le principes des modules complémentaires : quand la page s'affiche tu fais un clic droit et tu cliques sur "afficher la source" il va afficher le code source tel qu'il l'a exécuté et là il devrait y avoir du code javascript
Si c'est le cas lance tes pages avec un autre navigateur : safari , firefox , ...
et tu compares
ok eone2, je l'avais fait déjà sur d'autres navigateurs c'était pareil et pour cause ? la source n'affiche que la source de la page principale mais pas la ou les frames qui sont dedans (j'ai un menu en iframe qui appelle une autre page html) d'où mon problème de comprendre où ce trouvait ce fichu script ? d'autant que je n'avais pas inséré le script dans cette page là ... c'est en vérifiant dans mon éditeur html toutes les pages appelées en <iframe> que j'ai trouvé, voilà !
merci

Cathy