Access denied [PHP/PDO/MYSQL] [Fermé]

Signaler
Messages postés
161
Date d'inscription
mardi 9 juin 2009
Statut
Membre
Dernière intervention
11 février 2013
-
Messages postés
161
Date d'inscription
mardi 9 juin 2009
Statut
Membre
Dernière intervention
11 février 2013
-
Bonsoir,

Voilà, j'ai monter un serveur LAMP, sur ma machine personnelle. Tous les services s'initialisent correctement, httpd, mysqld... PhpMyAdmin fonctionne sans souçis. Cependant, c'est mon site qui ne marche pas du tout à cause de la connexion à mysql via PDO. Mon erreur:

Erreur : SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: NO)


Voiçi mon script de connexion connect_db.php :
<?php

	try{

		$bdd = new PDO('mysql:host=localhost;dbname=nq', 'nq', '*******');

	}

	catch (Exception $e)

	{

		die('Erreur : ' . $e->getMessage());

	}

?>


J'ai configuré le php.ini et attribué les mêmes variables de connexion, mais rien n'y fait. Je cherche une solution sur google depuis maintenant longtemps, mais je suis désespéré et à bout de force. J'implore la communauté CCM.

Cordialement.
A voir également:

2 réponses

Messages postés
870
Date d'inscription
mardi 23 juin 2009
Statut
Membre
Dernière intervention
8 août 2012
90
Hello
Attention ton mot de passe n'est pas reconnu..
Erreur : SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: NO
Cette erreur là indique que si tu n'as pas changé le mot de passe il faut rien mettre --> pwd = "" ou login= "root"; pwd = "root"

A voir selon ce que tu as fait dans php.ini....
Normalement ton LAMP après installation devrait etre pret à fonctionner.
Moi j'ai MAMP en comparaison avec WAMP ça a fonctionné tout seul du premier coup ! Vive Mac lol
Messages postés
161
Date d'inscription
mardi 9 juin 2009
Statut
Membre
Dernière intervention
11 février 2013
13
Merci de ta réponse et désolé pour le retard de la mienne :)

J'ai essayé plein de choses mais rien ne marchait tampis, j'ai fait un serveur avec une debian, et aucuns problèmes. Je commence a croire que j'avais un problème avec le SElinux de fedora. Tampis, merci encore.