[Linux] Squid reverse proxy HTTP et HTTPS [Résolu/Fermé]

Signaler
Messages postés
17747
Date d'inscription
mardi 3 juillet 2001
Statut
Modérateur
Dernière intervention
11 mars 2015
-
Messages postés
17747
Date d'inscription
mardi 3 juillet 2001
Statut
Modérateur
Dernière intervention
11 mars 2015
-
salut a tous.
je cherche a mettre en place un reverse proxy sous Linux, grace a squid.
mon soucis est le suivant:
si je lui dit httpd_accel_port 80 tout seul cela fonctionne. Cependant si j'essaie de faire du HTTPS (port 443) ca passe plus.
si je lui dit httpd_accel_port 443 tout seul ca passe pas non plus. Apache me traite de tous les noms parceque je cause http sur le port 443, et si je tente un acces https ca passe pas...
enfin si je mets les deux lignes seule la derniere est prise en compte.
J'aimerais bien pouvoir utiliser apache en http ET en https...

si quelqu'un a une idee de piste, merci d'avance



.O No parachute? Wow! This is so cool!
(_)__
... Castor

4 réponses

Messages postés
2564
Date d'inscription
samedi 15 septembre 2001
Statut
Contributeur
Dernière intervention
3 novembre 2006
287
j'ai pas tout compris !!!!!!!!!!!!!!
mais va voir là , si ta toujours ton PB .
http://www.europe.redhat.com/documentation/rhl6.2/ssl-fr/s1-configuration-virtualhosts.php3

ange
Messages postés
17747
Date d'inscription
mardi 3 juillet 2001
Statut
Modérateur
Dernière intervention
11 mars 2015
113
bn non desole ange... c'est gentil mais ca ne correspond pas :-((
et oui j'aui toujours mon soucis avec squid...


.O No parachute? Wow! This is so cool!
(_)__
... Castor
Messages postés
2564
Date d'inscription
samedi 15 septembre 2001
Statut
Contributeur
Dernière intervention
3 novembre 2006
287
Alors je me decarcassasse !!!!!!!
et c'est toujours obscur .
sinon appache doit etre reconfiguré pour le https , à tu été voir là ?
http://www.apache-ssl.org/

ange
Messages postés
17747
Date d'inscription
mardi 3 juillet 2001
Statut
Modérateur
Dernière intervention
11 mars 2015
113
yop merci ange..
mais en effet apache supporte bien le https...
non la le soucis viens de mon proxy (squid) qui ne relaie pas le https, seulement le http...
étrange...
pour le moment j'ai biaisé, mais bon ca me satisfait a moitié....

.O No parachute? Wow! This is so cool!
(_)__
... Castor