Html W3C pas validé [Fermé]

Signaler
Messages postés
2
Date d'inscription
jeudi 8 juillet 2010
Statut
Membre
Dernière intervention
8 juillet 2010
-
Messages postés
2
Date d'inscription
jeudi 8 juillet 2010
Statut
Membre
Dernière intervention
8 juillet 2010
-
Bonsoirs,

J'ai un soucis dans la validation a mon code HTML.
Voici les erreurs :


# Line 22, Column 16: document type does not allow element "div" here; assuming missing "li" start-tag

<div id="corps">

# Error Line 30, Column 5: end tag for "li" omitted, but OMITTAG NO was specified

</ul>


# Info Line 22, Column 1: start tag was here

<div id="corps">

# Error Line 31, Column 6: end tag for element "div" which is not open

</div>


# Error Line 40, Column 6: end tag for element "div" which is not open

</div>


# Error Line 31, Column 6: Opening and ending tag mismatch: body line 10 and div

</div>


# Error Line 40, Column 6: Opening and ending tag mismatch: html line 3 and div

</div>


# Error Line 51: Extra content at the end of the document

<div id="pied">


Voici mon code complet :
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr">
  <head>
    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1" />
    <title>Ma page</title>
    <link href="style.css" rel="stylesheet" type="text/css" media="screen" />

  </head>
  <body>

  <a href="#" target="_blank"><img src="images/banniere.gif" alt ="" border="0" width="1262" height="100" /></a> 
  

<ul id="menu_horizontal">
  <li class="bouton_gauche"><a href="index.html"><img src="images/puceverte.gif" alt="accueil" />Accueil</a></li>
  <li class="bouton_gauche"><a href="devis.html"><img src="images/puceverte.gif" alt="devis" />Devis</a></li>
  <li class="bouton_gauche"><a href="#"><img src="images/puceverte.gif" alt="membre" />Membre</a></li>
  <li class="bouton_droite"><a href="contact.html"><img src="images/puceverte.gif" alt="contact"/>Contact</a></li>


<div id="corps">
<br />
   <h3><u>Multi Service A La Personne</u> :</h3><br />
<p>Le nouveau projet vient d'ouvrir.<br />
Mes cependant celas n'est que pour les personnes agées qui possédent internet.<br />
Prennais votre temps de repos a visitées le site.</p>
</div>
	
</ul>
</div>

<ul id="menu">
  <li><a href="index.html">Accueil</a></li>
  <li><a href="departement.html">Département</a></li>
  <li><a href="agrement.html">Agrement simple</a></li>
  <li><a href="services.html">Services +</a></li>
  <li><a href="partenaire.html">Partenaire</a></li>
</ul>
</div>	


<div id="pied">
  <p>Copyright Corporation 2010, tous droits réservés</p>
</div>

	
               
  </body>
</html>


Merci d'avance.

2 réponses

Messages postés
437
Date d'inscription
mercredi 29 juillet 2009
Statut
Membre
Dernière intervention
23 septembre 2010
74
Bonjour

Attention à bien ouvrir et fermer les balises au bon moment! J'appelle ça des erreur d'étourderie!

Relis correctement ton code en comptant les ouvertures et fermetures, et tu trouveras les problèmes. d'autant que les erreurs W3C sont claires.

Par exemple, ton premier <ul> n'est pas fermé, il y a un <div> qui le suit, c'est une erreur.

Après ce <div> vient la balise </ul> baladeuse qui n'est pas à sa place, puis un </div> qui ne sert à rien puisqu'il n'y a plus de div ouvert...

Après ton 2ème <ul> se trouve encore une balise </div> qui ne ferme rien car elle n'a pas été ouverte.

Il n'y a pas d'autres erreurs pour moi, en corrigeant ça le validateur devrait dire bravo.

Mais attention tout de même, le HTML c'est de la rigueur dans les balises!

Bon courage
Messages postés
2
Date d'inscription
jeudi 8 juillet 2010
Statut
Membre
Dernière intervention
8 juillet 2010

Merci :) sayais j'ai supprimer les </div>
vu qu'il n'y avées que les <ul id="menu">etc....
Il n'y avais pas besoin de </div> a la fin.