HELP ! Partage avec Mandrake 10.1 + KDE

[Résolu/Fermé]
Signaler
Messages postés
60
Date d'inscription
jeudi 25 novembre 2004
Statut
Membre
Dernière intervention
3 décembre 2008
-
Messages postés
60
Date d'inscription
jeudi 25 novembre 2004
Statut
Membre
Dernière intervention
3 décembre 2008
-
J'ai installé un Linux Mandrake 10.1 sur un PC...
Ca va à peu près... je cherche un peu dans les meus mais c'est sûrement normal au début !

Mais là où je cale... c'est dans le partage de fichiers et les droits d'accès.
J'ai partage un répertoire /home/chris/public.
Depuis un autre PC sous win-XP je peux voir le répertoire mais il ne me demande pas d'identifiant/mdp !

J'ai essayé avec un Mandrake 8.1 et tout va bien (sur windows, on me demande mon nom d'utilisateur, mot de passe et j'ai les droits en lecture ou en écriture commé prévu...
Sur la version 10.1, rien à faire, je n'y arrive pas !

D'autre part, sur 8.1 il y avait un outil SAMBA-SWAT qui permettait de configurer les accès par http://localhost:901. Pourquoi ça ne fonctionne plus sur Mdk10.1 ?


Merci de détailler votre réponse... je comprends pas encore tout

2 réponses


Slt
Ca doit etre du a un probleme dans le fichier smb.conf au niveau de la securité.
Donc tu ouvre ta console
tu te met en root: tu fais
su ( ca va te demander ton passe )
ensuite normalement tu dois etre sur le repertoire
root@localhost /nom utilisateur
tu tapes cd / ( tu va te retrouver sur la racine ) et la tu tapes
vi etc/samba/smb.conf ( ca ouvre le smb.conf )
la tu descend jusqu'a trouver ecrit en vert security = kelke chose tu met security = user.
pour se faire tu te met en mode insertion en appuyant sur la touche "i" tu effces tout ce qui y'a aprés le egal ensuite tu entre user tu appui sur echap quant ta fini. et ensuite et pour finir ":wq" sans les guillements voila tu relances samba
services smb start et voila c'est ok normalement.
Messages postés
60
Date d'inscription
jeudi 25 novembre 2004
Statut
Membre
Dernière intervention
3 décembre 2008
56
Merci.
Security = user était bien dans le fichier /etc/samba/smb.cfg
En fait j'ai du faire la config moi-même dans smb.cfg car le partage demandé sous konqueror ne faisait que des partages "public".
Pour info si d'autre on le même pb, j'ai mis à la fin de /etc/samba/net.conf :
[partage]
path=/home/chris/partage
valid users=chris
read only = no

puis dans la console smbpasswd -a chris

Bon courage...