Excel : formule SI sur intervalle de date

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
26 avril 2010
-
Messages postés
3
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
26 avril 2010
-
Bonsoir, j'ai besoin de l'aide de l'un d'entre vous

voici mon exemple c'est plus simple que d'essayer de vous expliquer :
Colonne A : Colonne B : Colonne C : Colonne D :
LIGNE 4 : 01/02/2010 04/04/2010 07/08/2010 07/09/2010

COLONNE E : je voudrais que la valeur 1 s'affiche si une date des colonnes A à D est comprise entre le 1er fev et le 28 fev 2010

Ma formule marche pour l'étude d'une seule colonne mais si je demande l'étude de l'intervalle A4:D4, j'ai une erreur dans le résultat :
Voici ma formule : =SI(ET(A4>=DATE(2010;2;1);A4<=DATE(2010;2;28));1;"") : ça marche
si je mets : =SI(ET(A4:D4>=DATE(2010;2;1);A4:D4<=DATE(2010;2;28));1;"") : message d'erreur de formule

Merci de m'aider, je suis complétement noyée
A voir également:

3 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 529
bonjour

Tu peux essayer ceci qui devrait te donner ton résultat :

=SI(SOMMEPROD((MOIS(A4:D4)=2)*(ANNEE(A4:D4)=2010))=0;"";1)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
24198
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 926
Bonsoir,

Autant utiliser le mois....
Avec:
=SOMMEPROD((MOIS(A4:D4)=2)*(ANNEE(A4:D4)=2010))
tu auras le nombre de date de février 2010

Si tu veux absolument un 1 alors :
=SI(SOMMEPROD((MOIS(A4:D4)=2)*(ANNEE(A4:D4)=2010))=0;0;1)

eric
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 529
Coucou Éric,

Premier pour une seconde, c'est rare ! mais nos neurones allaient dans la même direction.
Bonne nuit et à bientôt.
Messages postés
24198
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 926
Salut gb,

Non, beaucoup plus : 60 s !!!
J'suis déçu là ;-)
Bonne nuit à toi aussi
eric
Messages postés
3
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
26 avril 2010

Un grand Merci à vous deux
La formule fonctionne parfaitement
Bonne journée et sûrement à une prochaine fois