Xampp vs EasyPHP

Résolu/Fermé
cycy10
Messages postés
13
Date d'inscription
mardi 15 décembre 2009
Statut
Membre
Dernière intervention
2 septembre 2010
- 4 janv. 2010 à 09:38
cycy10
Messages postés
13
Date d'inscription
mardi 15 décembre 2009
Statut
Membre
Dernière intervention
2 septembre 2010
- 4 janv. 2010 à 15:04
Bonjour chers forumers,

Voilà mon problème: je reprends un projet de site internet (de gestion financière mathématiquement complexe et informatiquement simple). Je suis un quasi débutant en matière de webmastering et de programmation. Le programme a été réalisé avec Xampp et lorque j'ai récupéré tous les fichiers ".PHP" et "htm" qui fonctionnaient parfaitement sur la machine du concepteur en localhost, je me suis rendu compte que plus rien ne tournait rond sur la mienne sur laquelle j'ai installé EasyPHP! Le problème ne vient pas de la version de PHP utilisée pour créer le programme puisque mon EasyPHP tourne avec PHP5.3, elle-même uitlisée pour créer le programme et qui est tolérée par mon serveur apache...
Donc COMMENT REGLER LES PROBLEMES DE COMPATIBILITE DU LOGICIEL XAMPP VERS LE LOGICIEL EASYPHP ??

N'hésitez pas à me demander plus de détails si nécessaire, je serai très réactif sur cette page.

Merci d'avance!

8 réponses

rescue
Messages postés
1039
Date d'inscription
vendredi 16 novembre 2007
Statut
Contributeur
Dernière intervention
27 mars 2019
138
4 janv. 2010 à 14:47
Re,

On s'en fiche des 2 fichiers php.ini-development et php.ini-production.
Ce qu'il faut c'est le fichier php.ini qui tourne actuellement avec ton PHP.
C'est ce fichier là qu'il faut modifier et tu places la valeur par défaut que j'ai écrit plus haut.

Tu places :
error_reporting = E_ALL & ~E_NOTICE

Ensuite tu redémarre le serveur web

@+
1
rescue
Messages postés
1039
Date d'inscription
vendredi 16 novembre 2007
Statut
Contributeur
Dernière intervention
27 mars 2019
138
4 janv. 2010 à 09:47
Bonjour,

Le problème peut venir justement de cette version PHP5.3.
Car la question est : Est ce que cette application tournait sous un xampp avec un PHP5.3 ?

@+
0
cycy10
Messages postés
13
Date d'inscription
mardi 15 décembre 2009
Statut
Membre
Dernière intervention
2 septembre 2010

4 janv. 2010 à 10:06
oui cela tournait avec PHP 5.3 sous Xampp
0
rescue
Messages postés
1039
Date d'inscription
vendredi 16 novembre 2007
Statut
Contributeur
Dernière intervention
27 mars 2019
138
4 janv. 2010 à 10:19
Re,

Je suis surpris que la version Xampp soit déjà en PHP5.3 !

Alors c'est quoi les messages d'erreurs ?
Pour que l'on puisse diagnostiquer.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cycy10
Messages postés
13
Date d'inscription
mardi 15 décembre 2009
Statut
Membre
Dernière intervention
2 septembre 2010

4 janv. 2010 à 11:17
en fait, l'utilisateur remplit un formulaire dans lequel il rentre des informations (concernant son portefeuille financier). Lorsque j'implémente le script, il m'apparait le formulaire et toutes les cases à remplir comportent des erreurs. Plus précisemment tous mes "input" de type "text" ont comme "value": "undefined index" et ensuite la ligne ligne du script et le nom du fichier ou il y a une erreur. Or cette erreur n'existait pas sur la machine du concepteur. Xampp comprenait très bien les différentes clés... et avec EasyPHP, plus rien! (sachant que j'ai 10 000 lignes de code je ne peux pas tout reprendre!)
si tu entrevois une solution, fais moi signe. PS: dslé pour le langage approximatif, je débute.

THKS.
0
rescue
Messages postés
1039
Date d'inscription
vendredi 16 novembre 2007
Statut
Contributeur
Dernière intervention
27 mars 2019
138
4 janv. 2010 à 13:23
Re,

Rien de bien grave si ce n'est que ça.
Il faudra modifier la directive error_reporting = E_ALL et passer à error_reporting = E_ALL & ~E_NOTICE dans ton fichier php.ini
et redémarrer le serveur web après la modification.

@+
0
cycy10
Messages postés
13
Date d'inscription
mardi 15 décembre 2009
Statut
Membre
Dernière intervention
2 septembre 2010

4 janv. 2010 à 14:34
J'ai deux fichiers "ini": php.ini-development et php.ini-production et dans les deux, à la rubrique error_reporting j'ai déjà ceci:

; error_reporting
; Default Value: E_ALL & ~E_NOTICE
; Development Value: E_ALL | E_STRICT
; Production Value: E_ALL & ~E_DEPRECATED

dans php.ini-development j'ai également:
error_reporting = E_ALL | E_STRICT

alors que dans php.ini-production, il y a:
error_reporting = E_ALL & ~E_DEPRECATED

donc QUE FAIRE dès lors?

Et en plus je n'ai aucune idée du fichier ini qui tourne avec mon script actuellement (honte à moi) donc je suis toujours bloqué.
Merci de t'intéresser à mon problème en tout cas.
0
cycy10
Messages postés
13
Date d'inscription
mardi 15 décembre 2009
Statut
Membre
Dernière intervention
2 septembre 2010

4 janv. 2010 à 15:04
Merci pour ton aide prompte et ta clarté impeccable: CE problème est résolu.
Mais évidemment, j'en ai de nouveaux que je vais soumettre à la communauté si je n'arrive pas à déboguer le script tout seul (à bon entendeur...).

Merci encore RESCUE!
@+
0