Fonction NB.SI 2 critères texte distinct [Fermé]

Signaler
-
 Ronald -
Bonjour,

Je cherche une formule ou une solution répondant à une problématique précise.
J'ai épluché nombreux articles pouvant éventuellement m'aider, mais je n'ai rien trouver.

Voici ma problématique.

Nous dirons que mon tableau comporte 2 onglets.
Le premier contenant des données textes, le second me servant de synthèse chiffrée par rapport au premier.
La fonction NB.Si me permet d'incrémenter ma synthèse en fonction d'un seul critère, or j'ai besoin qu'il prenne 2 critères en compte.

La colonne D comporte des noms qui reviennent ex :

JULIEN
MARTIN
PIERRE
ROMAIN
MARTIN
PIERRE
PIERRE

La colonne G comporte : soit la mention "ko" soit elle est vide.
Ca donne donc :

JULIEN ko
MARTIN
PIERRE
ROMAIN
MARTIN ko
PIERRE ko
PIERRE ko

Dans ma synthèse nous trouverons le listing des personnes :
JULIEN
MARTIN
PIERRE
ROMAIN

Comment puis-je obtenir
JULIEN 1
MARTIN 1
PIERRE 2
ROMAIN 0

En gros comment incrémenter ma synthèse en respectant la condition :
Si X=Julien, ET Y= KO alors Z=1

D'avance merci

En espérant avoir été clair.

5 réponses

Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
176
bonjour;
ça marchera avec la fonction NB.SI.ENS()
=NB.SI.ENS(A1:A10;"martin";B1:B10;"KO")
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Merci pour cette proposition intéressante !
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 418
bonjour

Avec la fonction SOMMEPROD :
=SOMMEPROD((Feuil1!D1:D10=A1)*(Feuil1!G1:G10="ko")*1)
bonjour
je ne saisis pas l'utilisation de NB.SI ce n'est pas grave vois si cela te conviens
http://www.cijoint.fr/cjlink.php?file=cj200909/cij2NhvBH8.xls
Re bonjour et merci a tous pour votre aide,

NB.SI ENS ne fonctionne pas je suis sous 2003,
Parcontre effectivement la fonction SOMMEPROD fonctionne, mais elle à ses limites,

Pour répondre à gbinforme

J'ai testé : =SOMMEPROD((Feuil1!D1:D10="MARTIN")*(Feuil1!G1:G10="ko"))

Et ça fonctionne bien, sauf que j'ai omis un détails, Ma colonne "D" (martin...) n'est pas renseignée de valeurs brutes, mais d'une formule : "RECHERCHEV"
Est-il possible de combiner la recherche verticale avec la fonction SOMMEPROD et obtenir le même résultat ? Ou dois-je convertir en valeur brute les données inscrites dans ma colonne "D" ?

Merci encore une fois :)
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 418
bonjour

Ma colonne "D" (martin...) n'est pas renseignée de valeurs brutes, mais d'une formule : "RECHERCHEV"

Aucune importance, c'est la valeur de la cellule qui est prise en compte, saisie ou résultat de formule.

Dans ma synthèse nous trouverons le listing des personnes :
JULIEN
MARTIN
PIERRE
ROMAIN

Comment puis-je obtenir
JULIEN 1
MARTIN 1
PIERRE 2
ROMAIN 0


à côté de JULIEN (supposons A1), en B1 tu mets ta formule, pour obtenir ton 1 :
=SOMMEPROD((Feuil1!D1:D10=A1)*(Feuil1!G1:G10="ko")) 

et tu peux "tirer" ta formule vers le bas.