Creation des table sur mysql [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
dimanche 26 avril 2009
Statut
Membre
Dernière intervention
14 mars 2010
-
Messages postés
13
Date d'inscription
dimanche 26 avril 2009
Statut
Membre
Dernière intervention
14 mars 2010
-
Bonjour,
svp je suis debutante en programmation , j'essaie de créer une base de données sur mysql
j'ai créer la premiere table ca a marché et sur la 2eme ca plante et ca me donne un msg d'erreur que je px pas identifier
svp si klk 1 pourra m'aider la dessous je serai reconnaissante
merci d'avance

voila ce que ca me donne :
***********************************************************************
Erreur

requête SQL:

CREATE TABLE `librairie`.`produits` (
`Réf_produit` INT( 22 ) NOT NULL ,
`Nom_produit` VARCHAR( 200 ) NOT NULL ,
`Prix_produit` DOUBLE( 20 ) NOT NULL ,
`Dispo_produit` VARCHAR( 20 ) NOT NULL ,
`Type_produit` VARCHAR( 200 ) NOT NULL ,
PRIMARY KEY ( `Réf_produit` )
) ENGINE = InnoDB

MySQL a répondu:Documentation
#1064 - Erreur de syntaxe près de ') NOT NULL, `Dispo_produit` VARCHAR(20) NOT NULL, `Type_produit` VARCHAR(200) NO' à la ligne 1

1 réponse

Messages postés
1838
Date d'inscription
dimanche 14 juin 2009
Statut
Membre
Dernière intervention
24 juillet 2019
137
Bonjour,

j'ai créé votre table ainsi :

CREATE TABLE produits ( ici seulement produit
`Réf_produit` INT(22) NOT NULL ,
`Nom_produit` VARCHAR(200) NOT NULL ,
`Prix_produit` DOUBLE NOT NULL , ici pas de logueur
`Dispo_produit` VARCHAR(20) NOT NULL ,
`Type_produit` VARCHAR(200) NOT NULL ,
PRIMARY KEY ( `Réf_produit` )
) ENGINE = InnoDB


et enfin pa de blanc avant et après chaque longueur
Messages postés
13
Date d'inscription
dimanche 26 avril 2009
Statut
Membre
Dernière intervention
14 mars 2010

merciiii infiniment ca marche mnt :-D