((Excel)) Extraire une valeur d'une cellule [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
jeudi 2 juillet 2009
Statut
Membre
Dernière intervention
2 juillet 2009
-
Messages postés
2
Date d'inscription
jeudi 2 juillet 2009
Statut
Membre
Dernière intervention
2 juillet 2009
-
Bonjour,

Je veux extraire des valeurs d'une colonne à une autre sous une condition spécifique.

Je m'explique:

Dans la colonne A il y a tous mes valeurs (en $)
Dans la colonne B va être indiqué, disons, ma condition: "x"
Dans la colonne C va apparaître la valeur indiquée dans la colonne A lorsque je mets "x" dans la colonne B.

Évidemment, si je ne mets aucun "x" dans la colonne B, la colonne C sera vide.

J'ai avais trouvé par hasard une fonction qui me permettait faire ceci, mais j'ai perdu le lien et je n'arrive pas à le retrouver. Si je ne me trompe pas ça commençait à peu près comme ça: SI (..... idl()).

Merci à l'avance pour vos réponses!!! :))


* Reduce, Reuse, Recycle

Monik

3 réponses

Messages postés
42
Date d'inscription
jeudi 2 juillet 2009
Statut
Membre
Dernière intervention
25 avril 2012
19
J'ai dû souvent faire la même chose. J'avais une formule plus simple au lieu du "exact()" mais je ne retrouve pas. À défaut ceci fonctionne :

=SI(EXACT("x";B1);A1;"")


Où A est la colonne "chiffres" et B la colonne des "x"
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60685 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
jeudi 2 juillet 2009
Statut
Membre
Dernière intervention
2 juillet 2009

Wooaw... merci pour la vitesse de vos réponses! Les deux fonctionnent très bien!

MERCI MERCI! :)


* Reduce, Reuse, Recycle

Monik
Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
581
Bonjour,

Essayer en mettant en C1 :

=SI(B1="x";A1;"")

puis recopier vers le bas la cellule C1

A+