Configuration materiel S7-300 (siemens) [Fermé]

Signaler
-
Messages postés
1
Date d'inscription
lundi 11 mai 2015
Statut
Membre
Dernière intervention
11 mai 2015
-
Bonjour,

je vous expose mon probleme :

Voila la config materielle que j'ai à disposition :

- Automate Siemens S7-300 (CPU 315-2 DP, alim PS307 2A)
- CP 343-1 lean
- Passerelle PROFIBUS DP/AS-i LINK Advanced
- Modules compacts K45 (4x 1E/1S)
- IHM SIMATIC PANEL touch (sous windows CE)

Je suis actuellement en stage et je travail sur l'adaptation de ce module a un autre poste. Mon soucis principal est que je ne peux pas "bidouiller" pour voir comment fonctionne le tout étant donner que je n'ai pas le droit d'ecraser la config existante. Je peux uniquement telecharger la config existante depuis l'automate pour tester les E/S sur le bus ASi.

Mais la probleme!! je rapatrie la config depuis la mémoire de l'automate je passe en mode "En ligne" et là, le CPU et la passerelle sont en erreur avec pour message respectif : "Module existant et prêt à fonctionner, DEL d'erreur (SF)" et "Module existant et prêt à fonctionner, Erreur externe, E 2046 Module existant et prêt à fonctionner". Au niveau materiel diodes CPU "RUN" et "SF" alumées, diodes de la passerelle "CER" et "SF" allumées. De plus le soft (step7 V5.4 SP4) me dit que les configurations Online/Offline ne correspondent pas !

Voila je pense vous avoir exposé tout les symptomes que j'ai pu reperer. J'espere que quelqu'un aura l'idée lumineuse qui pourra me debloquer :)

En attendant je remerci deja toutes les personnes qui auront prendront le temps de me lire et de repondre ;)

Bonne journée!

6 réponses

Si t'as la LED rouge SF c'est "erreur globale"! Merci Siemens ;o(
Verifies :
- ta config
- si tt les esclaves sur ta lignes sont ok
- Si t'envois pas un block non compatible avec ton API
Est ce que tu utilises OB21 & OB22 ds ton prg ?
Autrement, si tu debutes en API fais un tour :
IRAN - PLC
IRAN PLC-https://sites.google.com/site/iranplcrt/Home

A+
12
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Salut Xerxes,
Je vois tu sais de quoi tu parles. STP j'ai un prg en S7, peux tu m'aider à le debeuguer?
Je dois le rendre pour début janvier. Et ça sera hyper sympa de ta part.
Je te l'envoie par mail, si tu veux bien de jeter un coup d'œil.
Merci d'avance
Bonjour , ma question n'as pas trop de rapport avec le sujet ci-dessus , mais quand meme.
je suis etudiant et j'ai des cours d'automatique (sur s7 et s5)
Et voici enfin ma question , il y a t'il un logiciel style a step7 5.4 capable de tourner sous les distribution de linux?J'ai tester d'installer avec wineHQ mais ca ne fonctionne pas, je ne demande pas de transferer mais juste de pouvoir ecrire mes programmes (LOG,LIST et GRAPH) et dans un espoir extreme un logiciel qui permette de configurer les ecran(style wincc ou protools).Est ce que cela est possible?
Merci
salut


Le voyant SF veut dire system fault, c'est une erreur due à la config matérielle
ou à la programmation.Pour trouver l'origine du probléme tu dois aller dans système cible/état du module/mémoire tampon diagnostic.Si tu veux approfondir
voici mon mail jspinto@club-internet.fr
tu peux suivé ses regle :
Nouveau Objet
simtic300
Rack ==>
Ps :tu choisie 2 A
CPU300
CPU300C et Tu choisie le 2 eme CHoix
Et voilaa Ta cofig l material
Messages postés
1
Date d'inscription
lundi 11 mai 2015
Statut
Membre
Dernière intervention
11 mai 2015

bjr, j'ai un automate s7-300 avant il marchait très bien j'ai voulu enregistré un programme sur la carte mémoire sa na pas marché car la memoire ne prouvé pas supporté mon programme ensuite quand j'ai voulu re- chargé un programme le voyant SF est allumé (rouge) et les entrées marche les sortie non le voyant RUN est éteint, que faire merci de bien vouloir me répondre.

salut,

tout d'abord, tu dois charger ta config complete, par le biais de HW config (si t'as tous les pilotes et que t'es à jour en soft, tu reccuperera tes parametres).
ensuite tu compare ta version ONLINE et OFFLINE, si différence, tu te mets en ligne, et tu fais etat du module, la tu vas avoir les différentes erreurs dans le tampon mémoire.

comme ca tu vas pourvoir trouver ce qui te genes.

pour les essais, tu peux aussi te renseigner avec tes fournisseurs siemens, ils peuvent preter des configs à certains client (j'ai déja fait).

si je peux t'aider, hésites pas....je travailles assez souvent sur siemens, mais c'est vraiment que c'est pas tres convivial et encore moins souple!!!

bye