Monter ext4

Résolu/Fermé
Utilisateur anonyme - 28 avril 2009 à 22:37
 Utilisateur anonyme - 28 avril 2009 à 23:30
Bonjour à tous ;)

Quelqu'un a t'il trouvé comment monter du ext4 depuis les autres systèmes?

Car fatalement la commande:

mount -t ext4 /dev/xxx /media/xxx 


ne fonctionne pas,

je souhaiterais savoir si quelqu'un a trouvé un patch ou une application.


Merci :)

7 réponses

Utilisateur anonyme
28 avril 2009 à 23:04
excellent!

donc je résume:

 tune2fs -E test_fs /dev/sda9


debugfs -w /dev/sda9


tune2fs -l /dev/sda9 |grep flags

qui doit répondre:
Filesystem flags:         signed_directory_hash test_filesystem 


et enfin:

mount -t ext4dev /dev/sda9 /media/jaunty


et ça roule :))

et en lecture/ecriture en plus

Merci beaucoup à vous deux ;)

2
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
28 avril 2009 à 22:51
1
mamiemando
Messages postés
31308
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 août 2022
7 394
28 avril 2009 à 22:38
Déjà, quel est le message d'erreur au moment de faire le mount -t ext4 ? Parce qu'il faut que ta version de mount et ton noyau supportent l'ext4 pour que ça ait une chance de marcher.

Bonne chance
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
28 avril 2009 à 22:42
Salut,

Affiche le résultat de
 uname -r
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Utilisateur anonyme
28 avril 2009 à 22:47
Salut :)

mount: unknown filesystem type 'ext4'


le noyaux c'est:

2.6.26-2-686


Je vais devoir upgrader de noyaux vers le 2.6.29 absolument? :/


0
mamiemando
Messages postés
31308
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 août 2022
7 394
28 avril 2009 à 22:49
Est-ce que tu as commencé par le début ?
http://doc.ubuntu-fr.org/ext4

Bonne chance
0
Utilisateur anonyme
28 avril 2009 à 23:30
Info:

pour le fstab c'est:

[partition] [point de montage] [type] [options] [dump/pass]
/dev/sda9 /media/jaunty ext4dev defaults 0 0

et
umount -a
mount -a


ne revoie pas de message d'erreur,merci :))
0