Excel Somme de cellule selon 2 criteres texte

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
mardi 31 mars 2009
Statut
Membre
Dernière intervention
22 avril 2009
-
Messages postés
3
Date d'inscription
mardi 31 mars 2009
Statut
Membre
Dernière intervention
22 avril 2009
-
Bonjour,

question toute bete mais malgré tous vos anciens post je n'ai pu resoudre :

sous Excel (version 2003) g deux colonnes :

voiture rouge
voiture blanc
camion rouge
voiture rouge
camion blanc


je cherche une formule qui me permettrait de connaitre combien ai je de voiture rouge sans utiliser les tableaux croises dynamique (bien sur aprés j'aimerai savoir le nombre de camion blanc,....)

Merci de votre aide

4 réponses

Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
125
Bonjour
=Sommeprod((A1:A10="Voiture")*(B1:B10="Rouge"))
Tu peux remplacer Voiture et Rouge par des cellules
Il est impératif que tes champs de recherche (A1:A10 et B1:B10) débutent et finissent à la même ligne
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
17300
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
3 décembre 2021
10 743
Bonjour,

Supposant que tu aies nommé tes deux colonnes :
- la première "vehicules"
- la seconde "couleur"

voici la formule :

=SOMMEPROD((vehicule="voiture")*(couleur="rouge"))

=SOMMEPROD((vehicule="camion")*(couleur="blanc"))

etc.

m@rina
Messages postés
3
Date d'inscription
mardi 31 mars 2009
Statut
Membre
Dernière intervention
22 avril 2009

super merci à tous
Messages postés
1745
Date d'inscription
mardi 11 mars 2008
Statut
Membre
Dernière intervention
22 mai 2017
248
 





A                               B                C                      D                      E

1      VÉHICULE           NBRE           voiture rouge     voiture blanc     camion rouge …
2      voiture rouge       5                   <formule>
3      voiture blanc        8
4      camion rouge      7
5      voiture rouge        3
6      camion blanc       13


<formule> : C2 = SOMME.SI($A:$A;C1;$B:$B) → doit te renvoyer 5, sauf erreur.

Ensuite, tu tires la formule sur D2, sur E2, …




Si tu as dans une cellule H1= "voiture" et I1 = "rouge", tu peux utiliser les deux critères ▼

C2 = SOMME.SI($A:$A;"="&H1&" "&I1;$B:$B)

[le "="& devant être facultatif …]



ou



C2 = "Le nombre de "&H1&" "&I1&" est égal à "&SOMME.SI($A:$A;"="&H1&" "&I1;$B:$B)