Pb de navigation (CSS)

Fermé
txiki
Messages postés
3928
Date d'inscription
mercredi 30 janvier 2002
Statut
Contributeur
Dernière intervention
6 avril 2022
- 26 nov. 2004 à 16:01
txiki
Messages postés
3928
Date d'inscription
mercredi 30 janvier 2002
Statut
Contributeur
Dernière intervention
6 avril 2022
- 26 nov. 2004 à 17:32
Salut à tous,
Voilà:j'ai un énorme souci dans des pages que je viens de créer, entièrement en css ( http://txiki.free.fr/graci/index.htm ).
Si vous cliquer sur auteur par exemple, puis de là, à déjà parus dans un bouquin, jusque là très bien !!!
Par contre, si maintenant on clique sur un autre bouquin, il ne trouve pas la page. Pourquoi ?
PS: J'ai créé l'index, avec tous les menus. Ensuite, j'ai fais des copier/coller en changeant le contenu de la partie droite. Et en les rennomant bien sur.
Il est vrai que je ne maîtrise pas bien les css mais je crois que je commence à comprendre.

Merci en tous cas a ceux qui sauront me trouver une solution où une piste....

http://abarka.free.fr
Un adulte assis voit plus loin qu'un jeune debout.

2 réponses

http://txiki.free.fr/graci/parus/parus/solstice.htm

Ton lien .. je pense que tu le construit de cette facon dans ton code :

<a href="parus/solstice.htm">XXXXX</a>


Et si tu veux que ca marche, faut toujours prendre le lien depuis la racine donc :

<a href="/parus/solstice.htm">XXXXX</a>


Remarque le slash devant ton lien ..

Salutations
0
Erdnax
Messages postés
2273
Date d'inscription
mercredi 1 octobre 2003
Statut
Contributeur
Dernière intervention
1 octobre 2007
496
26 nov. 2004 à 16:17
Salut,

Les liens pointent vers (par exemple) "parus/lutin.htm" donc le navigateur va aller chercher dans le dossier "parus" la page "lutin.htm". Mais le problème, c'est que l'on se situe déjà dans ce dossier, donc, il cherche un dossier innexistant.

Si tu as compris, tant mieux, si tu veux plus de précisions, dis-moi.

@+

______________________________________________________
...:::=============== ERDNAX ================:::...
0
txiki
Messages postés
3928
Date d'inscription
mercredi 30 janvier 2002
Statut
Contributeur
Dernière intervention
6 avril 2022
504
26 nov. 2004 à 17:32
Salut à tous les deux et merci pour vos réponses,
J'avais déjà tenté avec le / mais sans plus de succès. Du coup j'ai tout mis à la racine, en local et en supprimant tout ce qui précéde le nom du fichier.
En fait, je crois qu'il s'agit d'un problème de rafraichissement car si, avant de cliquer directement sur un ouvrage on fait "précédent" alors là, on y accède. C'est C... avant de cliquer sur un lien, il faut revenir ???? Je n'avais jamais eu ce Pb avant.

Autre chose, chaque fois que j'ouvre un fichier avec Dream, au moment de le fermer il me demande de l'enregistrer, même si je n'y ai rien fait. ??? Autre bizarrerie.....

Je crois que je vais en etre réduit a passer par la méthode habituelle de Dream pour afficher/masquer les calques, et là, c'est pas gagné...
merci quand même... En plus! comble de malheur! je ne peut uploader les fichiers sur son compte à elle car elle a un forfait 50 h chez free, comme moi. Et le login est le n° de tel. Peut-etre que je vais établir une connexion gratuite et passer par là.... je vais voir.


http://abarka.free.fr
Un adulte assis voit plus loin qu'un jeune debout.
0