Probleme WampServer

Résolu
Bonjour,
J'ai installé wamp il y a quelques jours pour mon site web. Pour la partie administration je devais enlever le serveice "register globals". Donc j'ai fait ceci mais maintenant quand je veux le remettre il me dit:

"Could not execute menu item (internal error) [Exception] Could not perform service action: Le service n'a pas été démarré"

Voila sur la petite icone dans la barre en bas a droite il est jaune au lieu d'etre blanc et il y a un petit cadenas. Wamp ne veut plus se mettre Online.

Merci d'avance
Usirros
Configuration: Windows Vista
Firefox 3.0.7

13 réponses

Résumé de la discussion

Un problème lié à WampServer survient lorsque le service Apache ne démarre plus après des ajustements administratifs, avec l'erreur Could not execute menu item (internal error) et l’icône passant au jaune. Plusieurs répondants attribuent ce blocage au port 80 déjà utilisé, notamment par Skype, et proposent de modifier le port dans le fichier httpd.conf (par ex. 8080) ou de fermer Skype pour rétablir le service. En parallèle, certains indiquent qu’un démarrage manuel du service Apache ou la gestion des pare-feu et antivirus peut être nécessaire lorsque le port est bloqué. Des informations complémentaires précisent que d’autres programmes peuvent occuper le port 80 ou que des paramètres réseau doivent être ajustés, ce qui peut expliquer une reprise du fonctionnement après vérifications.

Bobot (l’IA à votre service)
  1. vous pouvez aussi changer le port en
    cliquant sur l'icone wampserver >> apache >> httpd.confg >> dans le fichier texte qui apparait vous rechercher la ligne 46 ou il ya noter# Listen 80
    vous remplacer 80 par 8080
    vous relancer wamp et au lieu d'ecrire localhost dan votre navigateur vous ecrirez plutot localhost:8080
    et c'est terminer
    41
    1. super ca a résolu mon problème d'internal erreur! merci
      0
    2. Merci
      0
    3. merci bien ça bien marché :)
      0
    4. JE T'AIME <3
      0
    5. Bonjour
      je viens de réinstaller Wamp pour avoir les dernière mise à jour PHP apache etc..
      et il me met également
      "could not execute menu item (internal error) [exeption] Could not perform service action: Le service n'a pas été démarré"
      le pc et tout neuf rien d'installer même pas d'antivirus et la console de test me mais que le port 80 n'est pas utilisé
      Je ne peut pas démarré le service apache séparément non plus.
      quelqu'un sais comment résoudre ce problème?
      merci d'avance
      0
  2. Aucun probleme j'avais juste skype d'ouvert.

    Usirros
    13
    1. Ouais bah moi skype est éteint et s fait toujours sa ...
      8
      1. Webmaster
        Merci Usirros, tu viens de résoudre mon problème ;-)

        Effectivement, Skype agissant comme serveur sur le port 80, il empêche WampServer de démarrer !

        Il suffit donc de fermer Skype !
        2
        1. Moi aussi, je voudrais bien savoir. Sa me fais exactement pareil ! J'ai quitté Skype mais il dit toujours pareil. Est-ce à cause de mon serveur KWARTZ entre internet et mon ordi ??? Si oui, pourriez-vous me dire ce qu'il faut que je change.

          Merci d'avance.
          2
          1. DSL du double post, c'est bon, sa marche. Il suffisait de quitter Skype et de recommencer la connexion.
            2
            1. Sinon tu doit faire
               Clique droit , ensuite Apache x.x.x , ensuite Service
              Ensuite démarrer service. Sa devrait démarrer tout seul... 
              2
              1. Certains anti virus prennent le contrôle sur les pare-feu part default de l'ordinateur , pour ceux à qui même si ils quitte skype / change le port continue , allez dans l'option de votre anti-virus , Pare-feu , Désinstaller . Le mieux serais tout de même de le laissez en route et d'autoriser le programme à ce connectez (ex wampserveur)
                1
                1. jai un probleme les services de wamp ne redémare pas l'icone reste orange. sachant que jai eu le meme message d'erreur. que dois je faire? merci
                  0
                  1. bonjour

                    moi aussi j'avais le meme problème mais c'est a cause de Skype, après avoir fermé Skype, le wamp a marché sans problème :-D, merci à vous tous.
                    0
                    1. desinstaller skype redmarrer l ordinateur tout simple

                      tu reinstalle ensuite skype et c est bon ^^
                      0