Apache & php
RésoluJe suis sur le point de developper un petit site web en php.
Ce site utilse une base postgresql.
J'utilise apache, mais je ne sais quel module, plugin je dois installé pour qu'apache interprete le code PHP.
Merci d'avance
Configuration: Windows XP Firefox 2.0.0.14
35 réponses
Le problème central est de faire interpréter PHP par Apache sous Windows XP lorsque l’on utilise PostgreSQL, et de déterminer quel module ou quelle DLL installer pour activer l’exécution du code PHP. Des solutions pratiques indiquent que la DLL php_pgsql de PHP 5.2.6 est défectueuse et qu’en remplaçant php_pgsql.dll par celle de PHP 5.2.5 dans le dossier ext, tout recommence à fonctionner. Des solutions alternatives évoquent l’installation de WAMP ou le déplacement de toutes les DLL PHP et PHP/ext dans le répertoire Apache/Bin avant redémarrage, afin de contourner des chemins ou des dépendances. Par ailleurs, certains éléments signalent que l’erreur « module introuvable » peut persister malgré le fichier existant, pointant vers des incompatibilités propres à la version PHP utilisée.
-
ca y est, j'ai la solution.
c'est la dll de la version php 5.2.6 qui est vérolée.
en copiant php_pgsql.dll de la version 5.2.5 dans le répertoire c:/wamp/bin/php/php5.2.6/ext à la place de la dll de la version 5.2.6, ça marche -
ContributeurSalut,
C'est relativement facile : tu dois juste décompresser une archive, et dire à Apache de charger un module en plus. T'as toutes les infos qu'il faut ici.
@Bientôt -
merci, je regarde cela.
-
En fait, j'ai opté pour l'installation de wamp2.
Cela fonctionne, mais hélas, j'ai toujours un problème avec php qui refuse la dll -> php_pgsql.dll
php_error.log me signale que cet dll est introuvable:
[03-Jun-2008 11:33:20] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
[03-Jun-2008 11:33:20] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
[03-Jun-2008 11:33:20] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
[03-Jun-2008 11:33:20] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
[03-Jun-2008 11:33:20] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
[03-Jun-2008 11:33:20] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
Et pourtant le fichier existe????????????????
PS: j'ai noté que le chemin etais spècifié avec des / alors que dans explorer c'est des \ ? -
j'ai appliqué ce que disais cet page https://www.somacon.com/p447.php
Mais rien a changé. Pfffff
Je dois peut etre ajouter un autre module, mais lequel? -
Enfin ca marche
J'ai fait plein de manip, mais je pense que la ré-installation de php5.2.6 a tous resolu.
(il fallait spécifier de pointer sur le fichier httpd.conf dans wamp pendant l'install)
2 jours de galère pour ça.
Ouf -
j'ai parlé trop vite...Rrrrrrrrrr
maintenant j'ai plus l'erreur dans mon fichier php_error.log
mais dans Apache_error.log
sous la forme:
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Program Files\\PHP\\ext\\php_pgsql.dll' - Le module sp\xe9cifi\xe9 est introuvable.\r\n in Unknown on line 0
dur dur -
ContributeurQu'est-ce qu'il y a dans ton fichier de configuration de PHP ? (juste la ligne de chargement du modul et celle de la configuration du fichier d'extensions).
T'as correctement paramètré le fichier des extensions ? (t'as dis qu'il existe donc ....) -
slt
si tu a wamp il suffit normalement de selectionner dans les extensions de php php_pgsql ! -
j'ai wamp et ca marche pas
la dll est presente ici
extension_dir = "c:/wamp/bin/php/php5.2.6/ext/"
mais dans mon apache_error.log
j'ai toujours
PHP Warning: PHP Startup: Unable to load dynamic library 'c:\\wamp\\bin\\php\\php5.2.6\\ext\\php_pgsql.dll' - Le module sp\xe9cifi\xe9 est introuvable.\r\n in Unknown on line 0 -
dacor mais lorsque tu fe 1 clique gauche sur licone wamp ta le menu ki s'affiche et dans php tu as extension, verifie que php_pgsql soit bien selectionner !
-
Depuis que j'ai installé php en + de wamp. C'est le bazard.
Le fichier de configuration php.ini qui fait foi est dans C:\Program Files\PHP
et il contiens bien l'extension php_pgsql.dll
Je crois que je vais tous desinstallé et recommancer a zero.
ps: je viens de ré-installé wamp et j'ai un message d'erreur au demarrage. Il ne trouve pas la dll LIBPQ.dll
mais il demarre tous de meme -
tu as installé php en plus de wamp ?
en effet je te conseil de tout sesinstallé et de refaire une install propre de wamp -
oui mais ca marchait pas non plus avant que j'install php5.2.6.
-
retour a la case depart Rrrrrrrrrrr
-
Telecharge bien la derniere version de wamp qui est 2.0x et normalement ca fonctionne !
tien moi o couran -
j'ai re-telechargé la version 2.0c (j'avais deja cet version).
Et re-installé ...toujours pareil. -
il ne trouve toujours pas la dll, cela ne vien til pa de ton os ?
-
Oui j'ai toujours la meme erreur dans php_error.log
[04-Jun-2008 12:28:03] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
[04-Jun-2008 12:28:03] PHP Warning: PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.2.6/ext/php_pgsql.dll' - Le module spécifié est introuvable.
in Unknown on line 0
2 x le meme message ?
Mais je n'ai plus l'erreur au demarrage de wamp (LIBPQ.dll introuvable) que j'avais lorsque j'avais ajouter l'install de php5.2.6-
Je réponds un peu tard, mais j'ai déjà rencontré cette erreur plusieurs fois, et dans mon cas, elle venait des fichiers php_psql.dll et php_pdo_pgsql.dll eux-mêmes pour les versions de php 5.2.6+ .
Pour résoudre le problème, j'ai copié des versions des dll que je savais bonnes et tout est rentré dans l'ordre.
-
-
et ne peut tu pas exporter ta base de données vers mysql qui est utilisée par wamp comme ca tu porras te servir de phpmyadmin
- 1
- 2