Problème zimbra ldap ne démarre plus

Résolu
Bonjour,

J'ai un problème j'ai mon serveur zimbra installé sur Ubuntu 12.04.5 LTS qui ne démarre plus, mon serveur dédié est un serveur que je loue chez OVH.

Voici ce que cela me fait :

root@liberty-chat:~# service zimbra start
Host liberty-chat.be
Starting ldap...Done.
Failed.
Failed to start slapd. Attempting debug start to determine error.
567715a2 backend_startup_one (type=mdb, suffix=""): bi_db_open failed! (80)


Je n'y comprends rien.

Est-ce que quelqu'un pourrait m'aider svp ?

Je peux vous donner des informations supplémentaires si nécessaire si vous me guidez car je ne sais pas lesquels vous avez besoin, c'est un ami qui me l'avait installé et je n'ai plus de contact avec celui-ci.

Merci d'avance.

5 réponses

  1. Ok mais je connais les variables a remplir mais a chaque fois zimbra remplace mon main.cf et sa me le faisait pas avant, il me le remet à 0.

    C'est sa que j'arrive pas a solutionné.
    0
    1. Modérateur
      Le message d'erreur semble indiquer que la chaîne daemon_directory n'est pas initialisée. Je t'invite à chercher les messages d'erreur que tu ne comprends pas dans google.
      https://forum.ubuntu-fr.org/viewtopic.php?id=88077

      Apparemment pour une installation classique (ie via un paquet) :

      daemon_directory = /usr/lib/postfix


      Bonne chance
      0
      1. Merci non je n'avais pas trouvé sa, en même temps je suis pas super doué en anglais.

        Suivant mes dossiers j'ai du un peu adapter la ligne en :
        /opt/zimbra/openldap-2.4.39.2z/sbin/slapindex -F /opt/zimbra/data/ldap/config entryDN


        Maintenant sa me met :


        root@liberty-chat:~# service zimbra start
        Host liberty-chat.be
        Starting ldap...Done.
        Starting zmconfigd...Done.
        Starting logger...Done.
        Starting mailbox...Failed.

        Starting snmp...Done.
        Starting mta...Failed.
        Starting saslauthd...done.
        postalias: fatal: bad string length 0 < 1: daemon_directory =
        postfix failed to start


        Je remarque que mon fichier /opt/zimbra/postfix-2.11.1.2z/conf/main.cf n'arrête pas de se dé-configurer tout seul.

        Une idée ? je cherche en même temps de mon coté.

        Merci d'avance.
        0
        1. Modérateur
          Bonjour,

          J'ai vu après une recherche google pas mal de gens qui avaient cette erreur. Sur ce post une solution est proposée, l'as tu essayée :
          http://community.zimbra.com/collaboration/f/1886/t/1089675

          Bonne chance
          0