Probleme safe mode
Résolu
Bonjour a tous,
J'ai un serveur lighttpd avec php et j'aimerai activer le safe mode dans php ...
Mais quand je modifie /etc/php5/cgi/php.ini et que je met "safe_mod = 1" en essayant de me connecter la page met "500 - Internal Server Error"
Pour info le propriétaire de index.php est www-data
Merci d'avance, si je n'ai pas été assez clair n'hésitez pas a me demander ^^
J'ai un serveur lighttpd avec php et j'aimerai activer le safe mode dans php ...
Mais quand je modifie /etc/php5/cgi/php.ini et que je met "safe_mod = 1" en essayant de me connecter la page met "500 - Internal Server Error"
Pour info le propriétaire de index.php est www-data
Merci d'avance, si je n'ai pas été assez clair n'hésitez pas a me demander ^^
3 réponses
-
C'est bon j'ai trouvé ma version php (5.4.45) mon probleme est résolu ^^
-- -
Merci pour ta reponce, j'utilise php5 et voici ce qui s'crir dans le error log quand j'essaye de me connecter
2015-11-03 12:10:21: (mod_fastcgi.c.1732) connect failed: Connection refused on unix:/var/run/lighttpd/php.socket-0
2015-11-03 12:10:21: (mod_fastcgi.c.3002) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
2015-11-03 12:10:21: (mod_fastcgi.c.2543) unexpected end-of-file (perhaps the fastcgi process died): pid: 4817 socket: unix:/var/run/lighttpd/php.socket-0
2015-11-03 12:10:21: (mod_fastcgi.c.3329) response not received, request sent: 712 on socket: unix:/var/run/lighttpd/php.socket-0 for /index.php?, closing connection
Merci d'avance et bonne soirée-
-
@PitetMerci je ne savais pas , comment savoir quelle version de php on utilise
Par contre c'est bizare car le probleme survient uniquement quand je met safe_mode = 1
-
-
Salut,
Quelle est ta version de PHP ? Que dit le message d'erreur des les logs de ton serveur web ?
Bonne journée