Probleme safe mode [Résolu/Fermé]

Signaler
Messages postés
164
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
8 septembre 2016
-
Messages postés
164
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
8 septembre 2016
-
Bonjour a tous,
J'ai un serveur lighttpd avec php et j'aimerai activer le safe mode dans php ...
Mais quand je modifie /etc/php5/cgi/php.ini et que je met "safe_mod = 1" en essayant de me connecter la page met "500 - Internal Server Error"
Pour info le propriétaire de index.php est www-data
Merci d'avance, si je n'ai pas été assez clair n'hésitez pas a me demander ^^



3 réponses

Messages postés
164
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
8 septembre 2016
3
Merci pour ta reponce, j'utilise php5 et voici ce qui s'crir dans le error log quand j'essaye de me connecter

2015-11-03 12:10:21: (mod_fastcgi.c.1732) connect failed: Connection refused on unix:/var/run/lighttpd/php.socket-0
2015-11-03 12:10:21: (mod_fastcgi.c.3002) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
2015-11-03 12:10:21: (mod_fastcgi.c.2543) unexpected end-of-file (perhaps the fastcgi process died): pid: 4817 socket: unix:/var/run/lighttpd/php.socket-0
2015-11-03 12:10:21: (mod_fastcgi.c.3329) response not received, request sent: 712 on socket: unix:/var/run/lighttpd/php.socket-0 for /index.php?, closing connection


Merci d'avance et bonne soirée
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2380
Date d'inscription
lundi 11 février 2013
Statut
Membre
Dernière intervention
11 juin 2021
446
Le safe mode a été supprimée de PHP depuis la version 5.4, et il n'est pas recommandé de l'utiliser.

Néanmoins je ne vois pas d'erreur en rapport avec le safe mode, le problème semble venir d'un module du serveur web mod_fastcgi
Messages postés
164
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
8 septembre 2016
3 >
Messages postés
2380
Date d'inscription
lundi 11 février 2013
Statut
Membre
Dernière intervention
11 juin 2021

Merci je ne savais pas , comment savoir quelle version de php on utilise
Par contre c'est bizare car le probleme survient uniquement quand je met safe_mode = 1
Messages postés
2380
Date d'inscription
lundi 11 février 2013
Statut
Membre
Dernière intervention
11 juin 2021
446
Salut,

Quelle est ta version de PHP ? Que dit le message d'erreur des les logs de ton serveur web ?

Bonne journée
Messages postés
164
Date d'inscription
dimanche 4 janvier 2015
Statut
Membre
Dernière intervention
8 septembre 2016
3
C'est bon j'ai trouvé ma version php (5.4.45) mon probleme est résolu ^^

--