Php pas interprété ...

Résolu
Bonjour à tous...

Sur un XP Pro, j'avais installé un Bigapache avec Apache2, Php4.x, MySql...
pour un serveur intranet.
Tout allait pour le mieux - mon phorum et mon wiki marchaient très bien jusqu'à ce que... quoi, je ne sais pas, manip hasardeuse de ma part ou bug, les liens du type \dossier\index.php renvoient... le contenu du php...
recherches, rédémarrages, passage au crible des httpd.conf et php.ini, rien de notable et je remarque que les liens sur \dossier\ exécutaient le index.php bon alors je change mes liens avant d'enquêter plus...
et puis au bout d'un moment, ça marche plus non plus, le lien me propose de télécharge index.php.... alors qu'un index.php3, lui est exécuté... et puis il ne l'est plus non plus
plus moyen de faire tourner un fichier php sur mon site
même à partir d'un autre poste du réseau

je cherche, je galère et je décide de jouer le tout pour le tout, j'installe un autre apache+php+mysql : un wamp avec apache2 et php5...
et là, alors que j'ai tout configuré au poil (enfin, ce que l'on configure quand on installe un apache) il se passe EXACTEMENT la même chose... pas moyen d'exécuter un fichier php...

comme ça ne marche pas mieux et que je ne veux pas me galérer à transférer ma base de données, je reviens à BigApache... je constate que les liens qui ne marchent pas *.php fonctionnent si je remplace par *.php?
Mais cette situation de secours n'est guère satisfaisante...

je suis désespéré, j'ai une présentation publique de mon intranet très bientôt et je ne comprends rien à ce qu'il se passe. Je ne trouve pas le côté rationnel de l'histoire....

Merci pour votre aide
Configuration: Bigapache avec Apache2, Php4.x, MySql sur Windows XP pro, en réseau windows avec serveur de domaine 2003

7 réponses

  1. Cette ligne dans le httpd.conf est commentée

    AddType application/x-tar .tgz
    #AddType application/x-httpd-php .php .php3 .phtml


    Il faut enlever le dièse et rédémarrer ton serveur.
    3
    1. oui...
      j'ai déjà essayé sans, avec
      et redémarré le serveur
      (bon sang, ce que j'ai pu le redémarrer, ce serveur !)
      mais c'est pareil...

      merci pour l'intérêt que vous portez à la chose...
      0
    2. ouais
      alors c'était bien ça au final
      SAUF
      que ça marche pas avec la combinaison ordi + navigateur avec lesquels je testais
      partout ailleurs sur le réseau, ça fonctionne
      alors je vais pas chercher à comprendre plus loin je me suis déjà assez pris la tête avec ça

      merci beaucoup en tout cas... vous m'avez enlevé une fière chandelle du pied.
      0
  2. Je viens d'avoir le meme probleme et je l'ai résolu.
    Dans mon cas, ca venait du fait qu'il fallait des <?php ?> et non les balises simplifiées <? ?>
    Il faut mettre à jour php.ini avec :
    short_open_tag = On
    2
    1. j'ai eu le même cas et je me suis cassé la tête pendant 2 jours...
      L'erreur vient que fait que c'est Ie qui tente d'interprété...
      Perso j'utilise EasyPhp, il de passer via le weblocal [ alias F7 ] pour que votre page soit interprétée correctement... Voici ce que j'ai fait
      1 - Créer un repertoire "test" dans le c:\[repertoire PHP]\www
      2 - créer un fichier .php que j'ai placé dans c:\...\www\test
      3 - lancer le weblocal de easyphp [ F7 ] -> vous retrouverez votre repertoire "test" -> et votre fichier php sera correctement intermrété...

      Voila...
      1
      1. voilà le httpd.conf

        ### Section 1: Global Environment
        ServerRoot "d:/BigApache/Apache"
        PidFile logs/httpd.pid
        Timeout 300
        KeepAlive On
        MaxKeepAliveRequests 100
        KeepAliveTimeout 15
        
        <IfModule prefork.c>
        StartServers         5
        MinSpareServers      5
        MaxSpareServers     10
        MaxClients         150
        MaxRequestsPerChild  0
        </IfModule>
        
        <IfModule worker.c>
        StartServers         2
        MaxClients         150
        MinSpareThreads     25
        MaxSpareThreads     75 
        ThreadsPerChild     25
        MaxRequestsPerChild  0
        </IfModule>
        
        <IfModule mpm_winnt.c>
        ThreadsPerChild 250
        MaxRequestsPerChild  0
        </IfModule>
        
        Listen 80
        Listen 443
        
        LoadModule access_module modules/mod_access.so
        LoadModule actions_module modules/mod_actions.so
        LoadModule alias_module modules/mod_alias.so
        LoadModule asis_module modules/mod_asis.so
        LoadModule auth_module modules/mod_auth.so
        LoadModule autoindex_module modules/mod_autoindex.so
        LoadModule dir_module modules/mod_dir.so
        LoadModule env_module modules/mod_env.so
        LoadModule imap_module modules/mod_imap.so
        LoadModule include_module modules/mod_include.so
        LoadModule info_module modules/mod_info.so
        LoadModule isapi_module modules/mod_isapi.so
        LoadModule log_config_module modules/mod_log_config.so
        LoadModule mime_module modules/mod_mime.so
        LoadModule negotiation_module modules/mod_negotiation.so
        LoadModule setenvif_module modules/mod_setenvif.so
        LoadModule status_module modules/mod_status.so
        LoadModule userdir_module modules/mod_userdir.so
        LoadModule proxy_module modules/mod_proxy.so
        LoadModule proxy_connect_module modules/mod_proxy_connect.so
        LoadModule proxy_http_module modules/mod_proxy_http.so
        LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
        LoadModule dav_fs_module modules/mod_dav_fs.so
        LoadModule rewrite_module modules/mod_rewrite.so
        LoadModule headers_module modules/mod_headers.so
        LoadModule vhost_alias_module modules/mod_vhost_alias.so
        LoadModule dav_module modules/mod_dav.so
        LoadModule auth_anon_module modules/mod_auth_anon.so
        LoadModule expires_module modules/mod_expires.so
        LoadModule ssl_module modules/mod_ssl.so
        LoadModule cgi_module modules/mod_cgi.so
        LoadModule python_module modules/mod_python.so
        LoadModule fastcgi_module modules/mod_fastcgi-2.4.2-AP20.dll
        
        #include Apache Tomcat/JBoss
        LoadModule jk_module "d:/BigApache/Apache/modules/mod_jk-2.0.42.dll"
        <IfModule mod_jk.c>
        JkWorkersFile "d:/BigApache/jboss/mod_jk/workers.properties" 
        JkLogFile "d:/BigApache/jboss/mod_jk/mod_jk.log"
        JkLogLevel info
        JKMount /*.jsp ajp13
        JkMount /JSexample ajp13
        JkMount /JSexample/* ajp13
        JkMount /HelloEJB ajp13
        JkMount /HelloEJB/* ajp13
        </IfModule>
        
        #include Apache modperl
        include "d:/BigApache/Apache/conf/mod_perl.conf"
        
        <IfModule mod_fastcgi.c>
        Alias /phpbin/ "d:/bigapache/php/"
        FastCgiServer "d:/bigapache/php/php.exe" -processes 5 
        AddType application/x-httpd-fastphp .php .php3
        Action application/x-httpd-fastphp "/phpbin/php.exe"
        Action application/x-httpd-php "/phpbin/php.exe"
        </IfModule>
        
        
        #LoadModule cern_meta_module modules/mod_cern_meta.so
        #LoadModule auth_dbm_module modules/mod_auth_dbm.so
        #LoadModule auth_digest_module modules/mod_auth_digest.so
        #LoadModule file_cache_module modules/mod_file_cache.so
        #LoadModule mime_magic_module modules/mod_mime_magic.so
        #LoadModule speling_module modules/mod_speling.so
        #LoadModule unique_id_module modules/mod_unique_id.so
        #LoadModule usertrack_module modules/mod_usertrack.so
        
        
        ### Section 2: 'Main' server configuration
        ServerAdmin thomas.andro@ac-montpellier.fr
        
        ServerName 10.134.35.24
        
        UseCanonicalName Off
        
        DocumentRoot "d:/BigApache/Apache/htdocs"
        
        <Directory />
            Options FollowSymLinks
            AllowOverride None
        </Directory>
        
        <Directory "d:/BigApache/Apache/htdocs">
            Options Indexes FollowSymLinks Includes
            AllowOverride None
            Order allow,deny
            Allow from all
            AddHandler type-map var
            AddHandler server-parsed .html
        AddHandler python-program .py
        PythonHandler mptest
            DirectoryIndex index.html index.asp index.html.var index.php index.php3 index.py
        </Directory>
        
        UserDir UserDir public_html
        
        DirectoryIndex index.asp index.html index.html.var index.php index.php3 index.py
        
        
        AccessFileName .htaccess
        
        <Files ~ "^\.ht">
            Order allow,deny
            Deny from all
        </Files>
        
        TypesConfig conf/mime.types
        
        DefaultType text/plain
        
        <IfModule mod_mime_magic.c>
            MIMEMagicFile conf/magic
        </IfModule>
        
        HostnameLookups Off
        
        LogLevel warn
        
        ## The following directives define some format nicknames for use with
        ## a CustomLog directive (see below).
        ErrorLog logs/error.log
        LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
        LogFormat "%h %l %u %t \"%r\" %>s %b" common
        LogFormat "%{Referer}i -> %U" referer
        LogFormat "%{User-agent}i" agent
        CustomLog logs/access.log combined
        
        ServerSignature On
        
        Alias /icons/ "d:/BigApache/Apache/icons/"
        
        <Directory  "d:/BigApache/Apache/icons">
            Options Indexes MultiViews
            AllowOverride None
            Order allow,deny
            Allow from all
        </Directory>
        
        Alias /manual/ "d:/BigApache/Apache/manual/"
        
        <Directory  "d:/BigApache/Apache/manual">
            Options Indexes
            AllowOverride None
            Order allow,deny
            Allow from all
        
            <Files *.html>
                SetHandler type-map
            </Files>
        
            SetEnvIf Request_URI ^/manual/de/ prefer-language=de
            SetEnvIf Request_URI ^/manual/en/ prefer-language=en
            SetEnvIf Request_URI ^/manual/fr/ prefer-language=fr
            SetEnvIf Request_URI ^/manual/ja/ prefer-language=ja
            SetEnvIf Request_URI ^/manual/ko/ prefer-language=ko
            SetEnvIf Request_URI ^/manual/ru/ prefer-language=ru
            RedirectMatch 301 ^/manual(?:/(de|en|fr|ja|ko|ru)){2,}(/.*)?$ /manual/$1$2
        </Directory>
        
        Alias /docs/ "d:/BigApache/docs/"
        
        <Directory  "d:/BigApache/docs">
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            Allow from all
        </Directory>
        
        Alias /mmcache/ "d:/BigApache/Apache/mmc_tools/"
        
        <Directory  "d:/BigApache/Apache/mmc_tools">
            Options Indexes FollowSymLinks MultiViews
            Order Deny,Allow
            Deny from all
            Allow from 127.0.0.1
        </Directory>
        
        
        ScriptAlias /cgi-bin/ "d:/BigApache/Apache/cgi-bin/"
        
        <Directory  "d:/BigApache/Apache/cgi-bin">
            AllowOverride None
            Options None
            Order allow,deny
            Allow from all
        </Directory>
        
        IndexOptions FancyIndexing VersionSort
        
        AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip
        
        AddIconByType (TXT,/icons/text.gif) text/*
        AddIconByType (IMG,/icons/image2.gif) image/*
        AddIconByType (SND,/icons/sound2.gif) audio/*
        AddIconByType (VID,/icons/movie.gif) video/*
        
        AddIcon /icons/binary.gif .bin .exe
        AddIcon /icons/binhex.gif .hqx
        AddIcon /icons/tar.gif .tar
        AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
        AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
        AddIcon /icons/a.gif .ps .ai .eps
        AddIcon /icons/layout.gif .html .shtml .htm .pdf
        AddIcon /icons/text.gif .txt
        AddIcon /icons/c.gif .c
        AddIcon /icons/p.gif .pl .py
        AddIcon /icons/f.gif .for
        AddIcon /icons/dvi.gif .dvi
        AddIcon /icons/uuencoded.gif .uu
        AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
        AddIcon /icons/tex.gif .tex
        AddIcon /icons/bomb.gif core
        
        AddIcon /icons/back.gif ..
        AddIcon /icons/hand.right.gif README
        AddIcon /icons/folder.gif ^^DIRECTORY^^
        AddIcon /icons/blank.gif ^^BLANKICON^^
        DefaultIcon /icons/unknown.gif
        
        ReadmeName README.html
        HeaderName HEADER.html
        IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t
        
        AddEncoding x-compress Z
        AddEncoding x-gzip gz tgz
        
        
        ##### Languages ######
        AddLanguage da .dk
        AddLanguage nl .nl
        AddLanguage en .en
        AddLanguage et .et
        AddLanguage fr .fr
        AddLanguage de .de
        AddLanguage he .he
        AddLanguage el .el
        AddLanguage it .it
        AddLanguage ja .ja
        AddLanguage pl .po
        AddLanguage kr .kr
        AddLanguage pt .pt
        AddLanguage nn .nn
        AddLanguage no .no
        AddLanguage pt-br .pt-br
        AddLanguage ltz .ltz
        AddLanguage ca .ca
        AddLanguage es .es
        AddLanguage sv .se
        AddLanguage cz .cz
        AddLanguage ru .ru
        AddLanguage tw .tw
        AddLanguage zh-tw .tw
        AddLanguage hr .hr
        LanguagePriority en da nl et fr de el it ja kr no pl pt pt-br ltz ca es sv tw
        ForceLanguagePriority Prefer Fallback
        
        AddDefaultCharset ISO-8859-1
        
        AddCharset ISO-8859-1  .iso8859-1 .latin1
        AddCharset ISO-8859-2  .iso8859-2 .latin2 .cen
        AddCharset ISO-8859-3  .iso8859-3 .latin3
        AddCharset ISO-8859-4  .iso8859-4 .latin4
        AddCharset ISO-8859-5  .iso8859-5 .latin5 .cyr .iso-ru
        AddCharset ISO-8859-6  .iso8859-6 .latin6 .arb
        AddCharset ISO-8859-7  .iso8859-7 .latin7 .grk
        AddCharset ISO-8859-8  .iso8859-8 .latin8 .heb
        AddCharset ISO-8859-9  .iso8859-9 .latin9 .trk
        AddCharset ISO-2022-JP .iso2022-jp .jis
        AddCharset ISO-2022-KR .iso2022-kr .kis
        AddCharset ISO-2022-CN .iso2022-cn .cis
        AddCharset Big5        .Big5       .big5
        # For russian, more than one charset is used (depends on client, mostly):
        AddCharset WINDOWS-1251 .cp-1251   .win-1251
        AddCharset CP866       .cp866
        AddCharset KOI8-r      .koi8-r .koi8-ru
        AddCharset KOI8-ru     .koi8-uk .ua
        AddCharset ISO-10646-UCS-2 .ucs2
        AddCharset ISO-10646-UCS-4 .ucs4
        AddCharset UTF-8       .utf8
        AddCharset GB2312      .gb2312 .gb 
        AddCharset utf-7       .utf7
        AddCharset utf-8       .utf8
        AddCharset big5        .big5 .b5
        AddCharset EUC-TW      .euc-tw
        AddCharset EUC-JP      .euc-jp
        AddCharset EUC-KR      .euc-kr
        AddCharset shift_jis   .sjis
        
        AddType application/x-tar .tgz
        #AddType application/x-httpd-php .php .php3 .phtml
        
        
        AddHandler type-map var
        
        #
        
        <IfModule mod_negotiation.c>
        <IfModule mod_include.c>
        Alias /error/ "d:/BigApache/Apache/error/"
        
        <Directory  "d:/BigApache/Apache/error">
                AllowOverride None
                Options IncludesNoExec
                AddOutputFilter Includes html
                AddHandler type-map var
                Order allow,deny
                Allow from all
                LanguagePriority en de es fr
                ForceLanguagePriority Prefer Fallback
            </Directory>
        
            ErrorDocument 400 /error/HTTP_BAD_REQUEST.html.var
            ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var
            ErrorDocument 403 /error/HTTP_FORBIDDEN.html.var
            ErrorDocument 404 /error/HTTP_NOT_FOUND.html.var
            ErrorDocument 405 /error/HTTP_METHOD_NOT_ALLOWED.html.var
            ErrorDocument 408 /error/HTTP_REQUEST_TIME_OUT.html.var
            ErrorDocument 410 /error/HTTP_GONE.html.var
            ErrorDocument 411 /error/HTTP_LENGTH_REQUIRED.html.var
            ErrorDocument 412 /error/HTTP_PRECONDITION_FAILED.html.var
            ErrorDocument 413 /error/HTTP_REQUEST_ENTITY_TOO_LARGE.html.var
            ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var
            ErrorDocument 415 /error/HTTP_SERVICE_UNAVAILABLE.html.var
            ErrorDocument 500 /error/HTTP_INTERNAL_SERVER_ERROR.html.var
            ErrorDocument 501 /error/HTTP_NOT_IMPLEMENTED.html.var
            ErrorDocument 502 /error/HTTP_BAD_GATEWAY.html.var
            ErrorDocument 503 /error/HTTP_SERVICE_UNAVAILABLE.html.var
            ErrorDocument 506 /error/HTTP_VARIANT_ALSO_VARIES.html.var
        
        </IfModule>
        </IfModule>
        
        <IfModule sapi_apache2.c>
        #AddInputFilter PHP .php
        #AddOutputFilter PHP .php
        #AddType text/html .php
        PHPIniDir "d:/bigapache/php"
        </IfModule>
        
        
        Alias /stat/ "d:/BigApache/Apache/statistic/"
        <Directory  "d:/BigApache/Apache/statistic/">
        AuthType Basic
        AuthName "Statistik"
        AuthUserFile "d:/BigApache/Apache/conf/userfile"
        require valid-user
        AllowOverride None
        Options Indexes
        order allow,deny
        allow from all
        </Directory>
        
        
        BrowserMatch "Mozilla/2" nokeepalive
        BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
        BrowserMatch "RealPlayer 4\.0" force-response-1.0
        BrowserMatch "Java/1\.0" force-response-1.0
        BrowserMatch "JDK/1\.0" force-response-1.0
        BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
        BrowserMatch "^WebDrive" redirect-carefully
        
        <Location /server-status>
            SetHandler server-status
            Order deny,allow
            Deny from all
            Allow from 127.0.0.1
        </Location>
        
        <Location /server-info>
            SetHandler server-info
            Order deny,allow
            Deny from all
            Allow from 127.0.0.1
        </Location>
        
        <IfModule mod_ssl.c>
            Include conf/ssl.conf
        </IfModule>
        
        ### Section 3: Virtual Hosts
        #
        # VirtualHost: If you want to maintain multiple domains/hostnames on your
        # machine you can setup VirtualHost containers for them. Most configurations
        # use only name-based virtual hosts so the server doesn't need to worry about
        # IP addresses. This is indicated by the asterisks in the directives below.
        #
        # Please see the documentation at 
        # <URL:http://httpd.apache.org/docs-2.0/vhosts/>
        # for further details before you try to setup virtual hosts.
        #
        # You may use the command line option '-S' to verify your virtual host
        # configuration.
        
        #
        # Use name-based virtual hosting.
        #
        #NameVirtualHost *
        
        #
        # VirtualHost example:
        # Almost any Apache directive may go into a VirtualHost container.
        # The first VirtualHost section is used for requests without a known
        # server name.
        #
        #<VirtualHost *>
        #    ServerAdmin webmaster@dummy-host.example.com
        #    DocumentRoot /www/docs/dummy-host.example.com
        #    ServerName dummy-host.example.com
        #    ErrorLog logs/dummy-host.example.com-error_log
        #    CustomLog logs/dummy-host.example.com-access_log common
        #</VirtualHost>
        
        
        
        1
        1. Voilà le PHP.ini (httpd.cong à suivre...)
          c'est une version 4.3.6
          j'ai enlevé les commentaires...
          merci pour l'intérêt que vous portez au problème !

          [PHP]
          
          ; This is the recommended, PHP 4-style version of the php.ini-dist file.  It
          
          engine = On
          short_open_tag = On
          asp_tags = Off
          precision    =  14
          y2k_compliance = Off
          output_buffering = 4096
          output_handler =
          zlib.output_compression = Off
          implicit_flush = Off
          allow_call_time_pass_reference = Off
          safe_mode = Off
          safe_mode_gid = Off
          safe_mode_include_dir =								
          safe_mode_exec_dir =
          safe_mode_allowed_env_vars = PHP_
          safe_mode_protected_env_vars = LD_LIBRARY_PATH
          disable_functions =
          highlight.string  = #CC0000
          highlight.comment = #FF9900
          highlight.keyword = #006600
          highlight.bg      = #FFFFFF
          highlight.default = #0000CC
          highlight.html    = #000000
          expose_php = On
          max_execution_time = 30     ; Maximum execution time of each script, in seconds
          memory_limit = 40M      ; Maximum amount of memory a script may consume (8MB)
          error_reporting  =  E_ALL
          display_errors = Off
          display_startup_errors = Off
          log_errors = On
          track_errors = Off
          error_log = "d:\BigApache\php\logs\php_error.log"
          warn_plus_overloading = Off
          variables_order = "GPCS"
          register_globals = ON
          register_argc_argv = Off
          post_max_size = 8M
          gpc_order = "GPC"
          magic_quotes_gpc = ON
          magic_quotes_runtime = Off    
          magic_quotes_sybase = Off
          auto_prepend_file =
          auto_append_file =
          default_mimetype = "text/html"
          include_path = ".;d:\BigApache\php\includes;d:\BigApache\php\pear"
          doc_root =
          user_dir =
          extension_dir = "d:\BigApache\php\extensions"
          enable_dl = On
          file_uploads = On
          upload_max_filesize = 20M
          allow_url_fopen = On
          
          extension=php_gd2.dll
          
          [Syslog]
          define_syslog_variables  = Off
          
          [mail function]
          ; For Win32 only.
          SMTP = 10.134.35.1
          
          ; For Win32 only.
          sendmail_from = me@localhost.com
          
          [Java]
          
          [SQL]
          sql.safe_mode = Off
          
          [ODBC]
          odbc.allow_persistent = On
          odbc.check_persistent = On
          odbc.max_persistent = -1
          odbc.max_links = -1  
          odbc.defaultlrl = 4096  
          odbc.defaultbinmode = 1  
          
          [MySQL]
          mysql.allow_persistent = On
          mysql.max_persistent = -1
          mysql.max_links = -1
          mysql.default_port =
          mysql.default_socket =
          mysql.default_host =
          mysql.default_user =
          mysql.default_password =
          
          [mSQL]
          msql.allow_persistent = On
          msql.max_persistent = -1
          msql.max_links = -1
          
          [PostgresSQL]
          pgsql.allow_persistent = On
          pgsql.auto_reset_persistent = Off
          pgsql.max_persistent = -1
          pgsql.max_links = -1
          
          [Sybase]
          sybase.allow_persistent = On
          sybase.max_persistent = -1
          sybase.max_links = -1
          sybase.min_error_severity = 10
          sybase.min_message_severity = 10
          sybase.compatability_mode = Off
          
          [Sybase-CT]
          sybct.allow_persistent = On
          sybct.max_persistent = -1
          sybct.max_links = -1
          sybct.min_server_severity = 10
          sybct.min_client_severity = 10
          
          [bcmath]
          bcmath.scale = 0
          
          [browscap]
          
          [Informix]
          ifx.default_host =
          ifx.default_user =
          ifx.default_password =
          ifx.allow_persistent = On
          ifx.max_persistent = -1
          ifx.max_links = -1
          ifx.textasvarchar = 0
          ifx.byteasvarchar = 0
          ifx.charasvarchar = 0
          ifx.blobinfile = 0
          ifx.nullformat = 0
          
          [Session]
          session.save_handler = files
          session.save_path = "d:/BigApache/tmp"
          session.use_cookies = 1
          session.name = PHPSESSID
          session.auto_start = 0
          session.cookie_lifetime = 0
          session.cookie_path = /
          session.cookie_domain =
          session.serialize_handler = php
          session.gc_probability = 1
          session.gc_maxlifetime = 1440
          session.referer_check =
          session.entropy_length = 0
          session.entropy_file =
          session.cache_limiter = nocache
          session.cache_expire = 180
          session.use_trans_sid = 1
          url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
          
          [MSSQL]
          mssql.allow_persistent = On
          mssql.max_persistent = -1
          mssql.max_links = -1
          mssql.min_error_severity = 10
          mssql.min_message_severity = 10
          mssql.compatability_mode = Off
          
          [Assertion]
          
          [Ingres II]
          ingres.allow_persistent = On
          ingres.max_persistent = -1
          ingres.max_links = -1
          ingres.default_database =
          ingres.default_user =
          ingres.default_password =
          
          [Verisign Payflow Pro]
          pfpro.defaulthost = "test-payflow.verisign.com"
          pfpro.defaultport = 443
          pfpro.defaulttimeout = 30
          
          [Sockets]
          sockets.use_system_read = On
          
          [com]
          
          [Printer]
          
          [mbstring]
          
          [FrontBase]
          
          [mmcache]
          extension="mmcache.dll"
          mmcache.shm_size = "8"
          mmcache.cache_dir = "d:\BigApache\tmp"
          mmcache.enable = "1"
          mmcache.optimizer = "1"
          mmcache.debug = "0"
          mmcache.check_mtime = "1"
          mmcache.filter = ""
          mmcache.shm_max = "0"
          mmcache.shm_ttl = "0"
          mmcache.shm_prune_period = "0"
          mmcache.shm_only = "0"
          mmcache.compress = "1"
          mmcache.keys     = "shm_and_disk"
          mmcache.sessions = "shm_and_disk"
          mmcache.content  = "shm_and_disk"
          
          0
          1. Contributeur
            J'ai le même problème il n'y a pas longtemp, mon serveur ne prenait plus en compte les index.php. Par contre pour ce qui est des fichiers php dont le nom est autre que index, pas de soucis :s
            C'est vrai que c'est gênant, je compatie. J'ai fais pareille que toi, j'ai remplacer par wamp5, rien marchait (mais pour d'autre raison) mais les fichiers php était interprétés. Donc j'ai remis ma config d'avant (easyphp modifié pour intégré php5) et miracle, tout refonctionne bien (mis à part l'index.php de easyphp mais c'est pas bien important).

            Donc je pense que ca doit venir d'apache uniquement, montre tes fichiers de conf.
            0
            1. Tu réécris les url de tes liens avec un htaccess ?

              Montre ton php.ini à tout hasard (entre les balises code)
              0