Excel: Nombre de valeurs distinctes dans une [Résolu/Fermé]

Signaler
-
Messages postés
16392
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
27 février 2021
-
Bonjour,
Je souhaite savoir le nombre de valeurs distinctes d'une colonne:
exemple: colonne A: valeurs des cellules 1 à 9: 1 2 3 4 5 6 4 5 6 : le resultat est 6 car il y a 6 valeurs différentes.
Merci pour votre aide

3 réponses

Messages postés
16392
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
27 février 2021
3 143
Bonjour,

Cette formule matricielle te compte les valeurs uniques dans la plage A1:A10
=SOMME(1/NB.SI(A1:A10;A1:A10))
formule matricielle à valider par Ctrl+maj+entrée (et non par "entrée" comme d'hab)

--
Cordialement,
Michel
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Bonjour

Hélas ca ne fonctionne pas si le tri se fait sur un texte et pas sur une valeur...
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 299
Bonjour bilouf,

la formule doit fonctionner pour du texte comme pour des chiffres.
Messages postés
16392
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
27 février 2021
3 143
bonjour

voir la source, notamment si il y a des cellules vides
http://xcell05.free.fr/pages/form/uniques.htm
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
235
Bonjour

une Formule matricielle (à valider avec Ctrl + Maj + Entree)
=Somme(1/nb.si(maplage;maplage))

Si la validation de la formule est correcte, des {} encadrent automatiquement la formule
Merci ++
Ca marche super bien. Mais à quoi correspondent cette syntaxe {} ? Et cette validation Ctrl+Mal+Ent?
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
235 > dmaestro
re: Bonjour Michel

Ctrl+Maj+Entree permet d'indiquer à Excel que c'est une Formule Matricielle
les {} Nous permet de savoir sur un classeur quelconque que nous avons à faire à une formule matricielle

Une Formule matricielle est une Formule qui travaille sur des matrices : Nb.si ne compare à l'origine une matrice à une valeur, mais dans le cas présent, la valeur testée est une matrice
>
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009

Merci pour cette réponse: après quelques essais, je découvre la puissance de la formule matricielle! Je vais me régaler!
Cdt
Denise
Et dans ACCESS, on fait comment ?