Php support EXIF

Bonjour,
je suis actuellement en train de construire mon site en local grace wamp server j'ai installr un modules de news php
avec un support d'images

le probleme c'est que lorsque je tente de mettre une image avec la news sa me fait sa

Fatal error: Call to undefined function exif_imagetype() in /www/sites/1/ifrance.com/v/i/virtualnetz/site/phpnews/admin.php on line 1483

J'ai fais des rechercher et a chaque fois j'ai trouvé

Pour activer le support EXIF en PHP, il suffit d'ajouter l'option de compilation --enable-exif .

Les utilisateurs Windows doivent s'assurer que les bibliothèques DLL php_mbstring.dll et php_exif.dll sont spécifiées dans le fichier php.ini . La bibliothèque php_mbstring.dll doit être chargée avant la bibliothèque php_exif.dll : pensez à ajuster votre php.ini

l'option de compilation je la rajoute ou ?
a quel en droit sur quel fichier ? est ce une extension ?
Configuration: Windows XP
Firefox 3.0.1

9 réponses

  1. Par défaut le php.ini n'est pas construit idéalement (http://forum.wampserver.com/read.php?1,359

    l'extension php_mbstring.dll DOIT être chargée AVANT php_exif.dll

    Concrêtement :
    - ouvrez le fichier php.ini
    - décommentez la ligne extension=php_mbstring.dll
    - coupez-collez la juste audessus de extension=php_exif.dll

    le php.ini doit donc ressembler à ça :

    blabla
    .
    .
    extension=php_mbstring.dll
    extension=php_exif.dll
    .
    .
    blabla
    1. loption de compilation, cest si tu teste ton code en ligne de commande, pour wamp, et il doi te manquer une librairie pour pouvoir utiliser exif
      va voir ici : http://www.siteduzero.com/tutoriel-3-31523-exif-lire-les-infos-d-une-image.html
      1. Meparece q cometieron un error

        no entiendo porque me banearon la cuenta (?)

        si hice algo malo no me di cuenta :S

        pero quisiera recuperar mi cuenta
        1. Bonjour, j'ai exactement le même problème !

          J'essaye par tous les moyens d'activer l'extension exif dans PHP et je n'y parviens pas du tout.

          J'ai le message 'Fatal error: Call to undefined function exif_imagetype() in ...'

          De plus, lorsque je fais function_exists('exif_read_data'), le résultat est false.

          Dans php_error.log, j'ai le message 'PHP Warning: PHP Startup: Unable to load dynamic library 'd:/wamp/bin/php/php5.2.6/ext/php_exif.dll' - Le module spécifié est introuvable. in Unknown on line 0'

          J'ai précise naturellement que j'ai activé :
          extension=php_mbstring.dll et extension=php_exif.dll

          J'ai placé la ligne php_exif.dll après celle de php_mbstring.dll

          Dans mon phpinfo, exif n'apparaît pas.

          Je tourne sous Windows Vista avec WAMP Server 2.0,
          version de PHP : 5.2.6
          version d'apache : 2.2.8


          Que puis-je faire pour arriver, enfin, à faire fonctionner cette extension qui me simplifierais bien la vie ?

          Merci d'avance pour toutes solutions.
          1. essai de rétélécharger la librarie et de la placer dans le répertoire ou elle est censé etre : d:/wamp/bin/php/php5.2.6/ext/
            1. sa veut dire koi serveur introuvable svp c'est urgent
              1. oua grav je sais pas mais jsui den la merde aussi svp repondez moi
            2. moi je veus mainteons pour me raizoudre se probelleme par ce que je jouer nuit et matin oh tout dofus des konare
              1. je peux pas me co c'est quoi ça m'on donne ça erreur:impossible de sauvgarde le fichier lang en local aider moi s'il vous plait