Problème d'un débutant sur le CSS [Résolu/Fermé]

Signaler
Messages postés
32
Date d'inscription
jeudi 10 juillet 2008
Statut
Membre
Dernière intervention
12 juillet 2011
-
 saming -
Bonjour,
je suis débutant sur le XHtml/CSS et débarque du Site des ZéroS pour un problème sur le CSS.
Quand par exemple dans la page machin.htm j'écris :
<span class="certain">certain</span>

Puis que dans la page truc.css j'écris :
.certain
{
color: rouge;
font-size: 18px;
}

Et bien ça ne marche pas . J'ai bien précisé le nom de la page css ( qui est dans le même dossier ) .
Mais non.
Et le comble c'est que "id" marche ! Mais je ne m'en sers pas ( pour l'instant ).
Bah :-) .
Bon eh bien dans l'attente d'une réponse , je vais relire mes leçons !
@+ et bonne journée !

1 réponse

Messages postés
45
Date d'inscription
vendredi 18 mai 2007
Statut
Membre
Dernière intervention
30 décembre 2010
24
Bonsoir,

Dans votre page machin.html, avez-vous bien déclaré la page css via la commande :
<link href="./truc.css" rel="stylesheet" type="text/css">
Cette déclaration se fait entre les balises <HEAD> et </HEAD>

En espèrent vous avoir aidez.
Tenez-moi au courant.
Bonne soirée.
Eh bien voila le code type html + css :
HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
   <head>
       <title>Titre</title>
       <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
       <link rel="stylesheet" media="screen" type="text/css" title="machin" href="machin.css" />
   </head>
   <body>
       <p>
	   <h2>Et un (class) <span class="truc">mot</span></h2><br />
	   <h2>Et un (id) <span id="machin">autre mot</span></h2><br />
	   <h3>Et un (rien) sous-titre</h3> 
	   </p>
   </body>
</html>

CSS:
.truc
{
color: blue;
}
#machin
{
color: blue;
}
h3
{
color: blue;
}

Donc si tu détecte un problème , n`hésite pas !
Messages postés
45
Date d'inscription
vendredi 18 mai 2007
Statut
Membre
Dernière intervention
30 décembre 2010
24 > saming
Bonsoir,

Ton code est correct.
Quand je l'exécute tout fonctionne correctement, il me met bien en bleu le texte voulu.
Bonne soirée.
>
Messages postés
45
Date d'inscription
vendredi 18 mai 2007
Statut
Membre
Dernière intervention
30 décembre 2010

Huh le problème était dans le header en fait.
Je me suis dis "bizarre" , j'ai donc relu le code et trouvé mon erreur.
Tu as donc résolu mon problème ! Même si !...
Donc merci , bonne jounée , et bonne chance pour tout !