Excel, pair ou impair [Résolu/Fermé]

Signaler
-
 Yann -
Bonjour,
Voiçi mon problème sous excel.
A partir d'un chiffre contenu en B2 par exemple, j'aimerai qu'en F22 s'effectue l'opération suivante: B2 MOINS 1 si B2 est impair, et B2 MOINS 2 si B2 est pair.
Donc une formule qui me permette de déterminer si un chiffre est pair à partir de quoi je lui applique une soustraction de 2, ou impair, à partir de quoi je lui applique une soustracttion de 1. En sachant que le chiffre de départ est toujours compris entre 5 et 15.
Exemple: si j'ai 8 en B2, que le calcul me fasse apparaître 8-2, soit 6, et que si j'ai 13, 13-1, soit 12.
Je suis guide en montagne et c'est pour faire un estimatif du nombre de chambres double ou single réservée en fonction de la taille des groupes... Et excel je découvre!
Merci 1000 voire 2000 fois si quelqu'un peut m'aider!
Configuration: Windows XP

3 réponses

Messages postés
37
Date d'inscription
mercredi 11 avril 2007
Statut
Membre
Dernière intervention
14 décembre 2008
22
Bonjour Théo,

Allons Y pour 1000 merci, ca suffira... :-)

Voila la formule a mettre en cellule F22 :

=SI(MOD(B2;2)=1;B2-1;B2-2)

Cette formule dit : Si le reste (MOD) de la division de B2 (ton chiffre) par 2 est égal à 1 (soit B2 est un chiffre impair), réaliser l'opération B1 - 1. Sinon (donc pour les chiffres pairs), réaliser l'opération B2 - 2

Tu peux aussi utiliser les formules est.pair et est.impair, toujours avec une condition, quelque chose du type :

=SI(EST.IMPAIR(B2)=VRAI;B2-1;B2-2)

Bon courage, et bons treks !!

IKEF
14
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

2000 merci c'est même pas suffisant pour te dire comme je suis content de voir que ta formule marche, après le temps que j'ai perdu à galérer et à m'énerver sans arriver à rien. Si un jour tu passes par le Cap Vert ou les Alpes je te paye un petit rhum!
Thanks.
Merci IKEF, Tu viens d'aider un autre guide de montagne (au Chili) 10 ans après le 1er guide :)
Messages postés
671
Date d'inscription
mardi 6 mars 2007
Statut
Membre
Dernière intervention
25 janvier 2011
294
Il y a les Fonctions :
EST.PAIR(cellule(s)) renvoie vrai si le nombre est pair et faux dans le cas contraire
EST.IMPAIR(cellule(s))
Dans le même style :
=SI(A1/2*2-TRONQUE(A1/2)*2=0; "pair"; "impair")

Cette fonction marche aussi : le chiffre se trouve dans la case A1.