Pas de souris sous VirtualBox-ose [Résolu/Fermé]

Signaler
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
-
Messages postés
2094
Date d'inscription
mercredi 18 juin 2008
Statut
Contributeur
Dernière intervention
2 décembre 2010
-
Bonjour, j'ai un gros soucis avec VirtualBox. Souhaitant virtualiser d'autres OS que ceux déjà installés sur ma machine, j'ai installé virtualbox-ose. Tout fonctionne, sauf la souris : impossible de faire capturer ma souris par le fenêtre virtualisée.

La souris est branchée sur un port USB.
Le clavier est branché sur un port USB, mais ne pose aucun problème.

L'installation a été effectuée sur mon Ubuntu 8.04 amd64.

J'ai recherché pendant pas mal de temps sur le net, mais j'avoue que là je sèche un peu...

A vot' bon coeur ;)

4 réponses

Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 154
HOOOOOOOOOOOOOONTEEEEEEEEEEEEEE SURRRRRRRRRRRRR MOIIIIIIIIIIIIIIIIIIIIIIIIIII !!!!

Trop habitué à règler mes param en ligne de co, j'avais juste oublié d'activer le support USB dans les préférences de VBox...

Allez-y, fouettez moi, c'est tout ce que je mérite...

Franz se tourne, se baisse et laisse choir son pantalon, permettant ainsi à l'auditoire médusé de découvrir deux jolies petites fesses rebondies...
5
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2094
Date d'inscription
mercredi 18 juin 2008
Statut
Contributeur
Dernière intervention
2 décembre 2010
199
non?
Messages postés
3356
Date d'inscription
vendredi 24 septembre 2004
Statut
Contributeur
Dernière intervention
5 octobre 2012
381
tu as essayé de reinstaller les additions clients ?
voire peut etre d'editer le xorg de ta machine guest

sinon personnellement j'evite la version OSE, je prefere prendre le .deb dispo sur le site de l'editeur, c'est pas libre mais bon ...
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 154
J'ai essayé les deux et je rencontre le même problème :S

Pour ce qui est des additions clients, quand je cliquais sur le menu, rien ne se passait. J'ai donc essayé de les installer à la main... sans succès :S
Messages postés
19599
Date d'inscription
vendredi 28 décembre 2001
Statut
Modérateur
Dernière intervention
2 janvier 2020
3 528
Bonjour,

Tu as testé avec la version entière livrée par SUN, l'avantage étant que les additifs sont déjà tous inclus ?
* Site source officiel : https://www.virtualbox.org/
* Téléchargements : https://www.virtualbox.org/wiki/Downloads

Il faut alors utiliser la version Binaries, -la page de téléchargement directe étant ici même. les paquets sont disponibles pour plusieurs OS.
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 154
Très bonne idée teutates, je n'y avais pas pensé.

C'est malheureusement sans effet... toujours pas de souris :S
Messages postés
2094
Date d'inscription
mercredi 18 juin 2008
Statut
Contributeur
Dernière intervention
2 décembre 2010
199 >
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015

salut,
En fait, ce sont tous tes périphériques usb qui ne sont pas pris en compte par la version OSE.
Donc, il faut utiliser la version normale de Sun.
Ensuite, il faut ajouter un truc de ce genre dans ton fstab.
usbfs /proc/bus/usb usbfs devgid=108,devmode=664 0 0
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 154 >
Messages postés
2094
Date d'inscription
mercredi 18 juin 2008
Statut
Contributeur
Dernière intervention
2 décembre 2010

Ah ! Une piste !

Je me doutais bien que c'était un problème avec l'usb ^^

Quelqu'un aurait-il les paramètres exacts à ajouter au fstab ?
Messages postés
2094
Date d'inscription
mercredi 18 juin 2008
Statut
Contributeur
Dernière intervention
2 décembre 2010
199
c'est un truc comme ça, mais il faut adapter en fonction de la distrib. Pour suse, ça marche