Calcul heure négative et positive sur Excel

Résolu/Fermé
aerodynamic77 Messages postés 60 Date d'inscription lundi 14 avril 2008 Statut Membre Dernière intervention 9 décembre 2010 - 15 avril 2008 à 10:32
 dragonestone - 20 juil. 2012 à 19:57
Bonjour à tous,
Voila, je suis responsable de projet en transport et j'ai créé dans un tableau excel pour le calcul d'arrivée prévue et réelle de camions.
A partir de la différence entre le prévisionnel et le réel, je voudrais ressortir un indice qualité avec une marge de manoeuvre. Je m'explique par cet exemple :

Camion 1
Heure d'arrivée prévue : 23h00
Heure d'arrivée réelle : 23h15
Ecart = + 0h15

Camion 2
Heure d'arrivée prévue : 22h00
Heure d'arrivée réelle : 21h00
Ecart = -1h00

Camion 3
Heure d'arrivée prévue : 21h00
Heure d'arrivée réelle : 1h00 le jour suivant
Ecart = +4h00

Camion 4
Heure d'arrivée prévue : 2h00
Heure d'arrivée réelle : 23h30 le jour précédent
Ecart = -2h30

A partir de ces infos, je recherche la formule pour calculer l'écart entre l'heure réelle et l'heure prévue en sachant que la plupart des camions arrivent la nuit et que les heures peuvent être à cheval sur deux jours.
Ensuite, je souhaite mettre une formule qui me dit : si l'écart est supérieur de 30 minutes (en plus ou en moins), le résultat est égal à 1 sinon résultat = 0.

La difficulté est de trouver une formule qui fonctionne bien avec le format horaire mais aussi avec les écarts positifs et négatifs, choses que je n'arrive pas.

Merci pour votre adie !

J'attends vos réponses avec impatience, mon PDG compte sur vous :)
A voir également:

4 réponses

Mike-31 Messages postés 18111 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 22 novembre 2022 5 013
16 avril 2008 à 21:47
Salut,

Le calcul des heures est plus délicat à traiter sur ce lien une variante proche de lepierre que je salut.

https://www.cjoint.com/?eqvTbaWU5m

A+

_______________________________________________________________
Vous cherchiez de l’aide. Les membres du forum, bénévolement étaient à vos côtés.
Ayez la gentillesse de nous dire si votre problème est résolu. Afin de classer la
Demande.
1
LePierre Messages postés 249 Date d'inscription samedi 8 mars 2008 Statut Membre Dernière intervention 2 août 2012 337
17 avril 2008 à 09:58
bonjour à vous deux

effectivement c'est une bonne solution. Le format horaire de l'écart est plus satisfaisant.
la formule de Mike-31 pourrait être simplifiée en : =SI(B24>B23;B24-B23;B23-B24)

bonne journée
0
aerodynamic77 Messages postés 60 Date d'inscription lundi 14 avril 2008 Statut Membre Dernière intervention 9 décembre 2010 3
21 avril 2008 à 17:52
ok je fais le teste en direct sur mon tableur et je reviens avec les résultats !
0