Excel Suppression du format date

Résolu/Fermé
diinee - 10 avril 2008 à 16:57
 Utilisateur anonyme - 2 avril 2012 à 09:46
Bonjour,
J'importe un fichier contenant la donnée 1/1 qui se convertit automatiquement en 01-Janv, quelle est l'option qui me permetterai d'empêcher cette conversion automatique et qui garderais ma données comme du texte.
J'ai essayé de changer le format de cellule mais ça ne marche pas et j'aimerai de pas avoir à modifier mon fichier.
Merci de votre aide!
+
A voir également:

7 réponses

LePierre
Messages postés
249
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
2 août 2012
336
10 avril 2008 à 17:00
bonjour
il faut simplement ajouter ' avant la donnée
exemple : '1/1
à plus
52
Je ne peux pas convertir manuellement mon fichier ce ne sont pas des données saisies et à partir du moment où je l'ouvre la convertion est effective et si je le remets en format texte il m'affiche 39448.
Y a-t-il une option pour empêcher quelque soit ma feuille excel cette convertion automatique???
0
Utilisateur anonyme
10 avril 2008 à 18:01
Bonjour,
Si on veut obtenir 1/1 en tant que texte il faut cocher "texte" (et non pas standard) à l'étape 3 sur3 de l'assistant d'importation de texte. Les autres données peuvent rester en standard.
Si l'importation est automatisée par une macro il faut choisir les instructions correspondantes dans la macro.
24
xkristi
Messages postés
4263
Date d'inscription
lundi 18 décembre 2006
Statut
Membre
Dernière intervention
5 mars 2022
562
10 avril 2008 à 17:31
tu sélectionnes la colonne
format
cellule
date
personnalisée et tu frappes jj mmmm aaaa

et tu auras ce résultat :
01 janvier 2008
12 septembre 2008
10
Utilisateur anonyme
2 avril 2012 à 09:46
Il faut prendre le problème à la source: directement lors de l'importation!
ok !...clic droit modifier la requête web -options - cocher désactiver la reconnaissance des dates et hop ! a +
8

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
dubcek
Messages postés
18534
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
12 août 2022
5 553
10 avril 2008 à 17:24
c'est un fichier .xls ou un fichier texte .csv qui est importé ?
39448 c'est parce que la cellule a été convertie en 01-jan
1
A la base c'est un csv mais j'aimerai que cette modification soit effective pour tous mes prochains classeur!
0
dubcek
Messages postés
18534
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
12 août 2022
5 553
10 avril 2008 à 17:01
en mettant la cellule au format texte ?
0
Il faut prendre le problème à la source: directement lors de l'importation!

Si on utilise la méthode "opentext" (avec des colonnes délimitées par des séparateurs), il faut modifier le paramètre "FieldInfo" et mettre quelque chose du genre:

FieldInfo:=Array(Array(1, 2), Array(2, 2), Array(3, 2))

Je n'ai toujours pas compris où il va pécher le 39448 quand on retransforme le type de données en "texte" a posteriori ... (soyons pragmatiques)
0