Cmd service -> bash: command not fount [Résolu/Fermé]

Signaler
Messages postés
121
Date d'inscription
jeudi 29 janvier 2004
Statut
Membre
Dernière intervention
30 mai 2008
-
Messages postés
121
Date d'inscription
jeudi 29 janvier 2004
Statut
Membre
Dernière intervention
30 mai 2008
-
Bonjour,


je teste pour la 1er fois redhat entreprise linux 5

j'ai des commandes comme la commande 'service" qui ne fonctionne pas

bash: service :commande not found

et pourtant 'man service' fonctionne??


merci d'avance

4 réponses

Messages postés
121
Date d'inscription
jeudi 29 janvier 2004
Statut
Membre
Dernière intervention
30 mai 2008
43
ok ca marche,
c'est donc mon path qui n'est pas complet.


Merci
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 825
Non, c'est que le répertoire "/sbin" ne fait pas partie du PATH d'un simple utilisateur.

D'autre part, sous "RedHat" (c'est aussi vrai pour les 1ères versions de Fedora-Core), le fait de passer en root via la commande "su" n'initialise pas les variables d'environnement du superutilisateur, il faut employer obligatoirement "su -", voir à ce sujet Utiliser la commande "su"
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 825
Salut,

Essaye "/sbin/service" ;-))
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 517
Salut,

whereis service
pour trouver le chemin de binaire
Messages postés
121
Date d'inscription
jeudi 29 janvier 2004
Statut
Membre
Dernière intervention
30 mai 2008
43
OK

Merci pour ton expliquation. Maintenant je comprend mieux.


Tcho