Bouton radio coché par défaut

Résolu/Fermé
vérokit Messages postés 68 Date d'inscription vendredi 18 janvier 2008 Statut Membre Dernière intervention 9 septembre 2008 - 18 janv. 2008 à 13:25
 vérokit - 22 janv. 2008 à 10:55
Bonjour,
Je rencontre un énième problème lors du débogage d'un projet en Visual Studio 2005 : une boîte de dialogue constituée de 8 boutons radio, possède le code suivant :

"" Private Sub ALARM01_Load () Handles MyBase.Load

Option1.Checked = False
Option2.Checked = False
...
Option8.Checked = False ""

Le problème se situe à l'ouverture de la boîte de dialogue : le bouton radio 1 est déjà coché ! Je peux nénamoins le décocher avec une commande "remise à zéro" (Command2) dont le code est :

"" Private Sub Command2_Click () Handles Command2.Click

Option1.Checked = False
Option2.Checked = False
...
Option8.Checked = False """

Quelqu'un a une idée sur la question ?

Merci d'avance
A voir également:

4 réponses

choubaka Messages postés 39132 Date d'inscription jeudi 4 avril 2002 Statut Modérateur Dernière intervention 5 décembre 2022 2 094
18 janv. 2008 à 13:30
salut

je crois que dans le cas des boutons radio (en java c'est le cas), il doit y en avoir toujours un de coché ..

pour résoudre ceci, il faut opter pour les cases à cocher ..

0
de ma part je crois que tu peux essayer avec les entiers 0=false et 1=true
option1.checked=0
0
vérokit Messages postés 68 Date d'inscription vendredi 18 janvier 2008 Statut Membre Dernière intervention 9 septembre 2008 10
18 janv. 2008 à 14:22
Bonjour,
Merci à vous de m'avoir répondu.
Pour répondre à Choubaka, en VB6.0 il est possible de n'avoir aucun bouton de cohé à l'avance, c'est pour ça que je voulais obtenir la même chose en Visual Studio.
Je vais tenté de remplacer par des cases à cocher
Pour répondre à cesar9, j'ai essayé de remplacer par 0 ou 1, je conserve mon problème.
Ce qui me perturbe c'est que je n'ai qu'un bouton qui est déjà coché...

Merci de votre aide
0
Ca y est, j'ai trouvé !
Il suffisait de modifier la nature du contrôle frame qui réunissait les boutons radio et de le changer en groupbox !
Cependant, c'est ma commande de mise à zéro qui ne marche plus...
0