Intégration de cURL à Apache

[Fermé]
Signaler
-
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
-
Bonjour,

J'ai besoin de cURL dans un script php (c'est une classe toute faite qui se connecte au serveur d'msn).

Actuellement, mon script me sort : "Fatal error: Call to undefined function curl_init() in /var/www/msn.php on line 386"

J'ai donc installé cURL (décompression des sources et compilation). cURL fonctionne.

Mais rien n'a changé dans mon script php.

Que dois-je faire ? Recompiler php ? Un truc comme ça ?

Je ne sais pas faire !

Merci (:

9 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 560
Pourquoi n'installes tu avec le gestionnaire de paquets?
regarde ce qu'il y a sous debian
lami20j@debserv:~/trash$ aptitude search curl | grep php
p   php4-curl                       - CURL module for php4
p   php5-curl                       - CURL module for php5
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

E: Impossible de trouver le paquet php5-curl
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 560
cette commande te donne quoi?
aptitude search curl | grep php
v php4-cgi-curl -
p php4-curl - CURL module for php4

J'aurais apprecié php5 moi...
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 560
affiche le résultat de
cat /etc/apt/sources.list
Il y en a juste un peu pas assez, rien de grave (:

eb ftp://mir1.ovh.net/debian/ sarge main
deb-src ftp://mir1.ovh.net/debian/ sarge main
deb https://www.debian.org/security/ sarge/updates main
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 560
ben, peut être qu'il faut mettre à jour ton système et de passer en etch qui est la dernière distribution stable

donc au lieu de sarge tu mets etch et tu fait un
apt-get update
apt-get upgrade
mais avant de faire ça affiche ce que te donne
uname -r
En fait ça va aller merci, je ferai ça plus tard, parce que j'ai trouvé un petit stagiaire bien sympa qui me le fait à ma place ;-)

Merci quand même !
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 560
ce qui ne t'empêche pas de mettre le système à jour ;-))