Problème de formule

Résolu/Fermé
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 - 29 déc. 2022 à 21:28
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 - 30 déc. 2022 à 17:15

Bonjour,

Sur ma feuille1 intitulé "shift", j'ai un tableau récapitulatif de mes horaires faite durant le mois, semaine et jour avec pour chaque cellule une liste déroulante de toute mes horaires possibles (ex: 17:00-03:00) 

Dans ma feuille 2 intitulé "total", j'ai une liste détaillée de toute les horaires possibles et dans la cellule d'à côté, le nombre de fois que j'ai fais ladite horaire. Ex: sur A3 est 17:00-03:00 et si j'ai fais cette horaire 6 fois dans le mois, sur A4 est écrit 6. 

Maintenant mon problème c'est que j'ai envi d'automatiser le changement de chiffre. Donc si je rajoute une septième fois "17:00-03:00" dans "shift" je veux que ma cellule A4 dans "total" se change automatiquement en 7

J'ai essayé :

=NB(shift!A:A,"17:00-03:00")

Et d'autres variation de cette formule mais a chaque fois ça me marque #ERROR!

si quelqu'un pouvait m'aider sur ce coup là ce serait super.

Merci d'avance

Totomann 


Android / Chrome 108.0.0.0

A voir également:

8 réponses

Misterlolo57 Messages postés 12 Date d'inscription jeudi 29 décembre 2022 Statut Membre Dernière intervention 30 décembre 2022 10
30 déc. 2022 à 14:43
  • Dans la cellule A4 de ta feuille "total", entre la formule suivante : =NBVAL(shift!A:A,"17:00-03:00")
  • Appuie sur la touche F9 pour mettre à jour la référence croisée dynamique.

Cette formule va compter le nombre de fois où "17:00-03:00" apparaît dans la colonne A de ta feuille "shift" et mettre à jour le nombre de fois où tu as effectué cet horaire dans la cellule A4 de ta feuille "total" chaque fois que tu ajoutes un nouvel horaire "17:00-03:00" dans ta feuille "shift".

2
PapyLuc51 Messages postés 4238 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 22 février 2024 1 378
Modifié le 30 déc. 2022 à 15:45

Mais si ça fonctionne https://www.cjoint.com/c/LLEoAqG6Jez

Mais comme je le mentionnais dans ma dernière intervention si tu veux avoir les nombres mois par mois il faut changer ton tableau.

Voici une esquisse de ce que ça peut donner et pour ce tableau plus de NB.SI mais une SOMMEPROD;

https://www.cjoint.com/c/LLEoDBU2aMz

Cordialement

1
jee pee Messages postés 39297 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 22 février 2024 9 184
29 déc. 2022 à 22:44

Bonjour,

NB() additionne des nombres, pour comparer à une valeur il faut NB.SI()    =NB.SI(shift!A:A,"17:00-03:00")


0
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 74
Modifié le 30 déc. 2022 à 05:57

=NB.SI(shift!A:A,"17:00-03:00") est l'une des variantes que j'ai essayé et qui hélas ne fonctionne pas. Le même message d'erreur s'affiche 

Je te laisse voir ici : https://ibb.co/gDH8q3M

merci pour ton aide 

0
PapyLuc51 Messages postés 4238 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 22 février 2024 1 378
Modifié le 30 déc. 2022 à 06:50

Bonjour,

Salutations à jee pee

Puisque l'horaire est répété dans la cellule A3 du feuillet "total", pourquoi ne pas mettre tout simplement =NB.SI(shift!A:A;A3).

Si incrémentation vers la droite pour le nombre des autres horaires ne pas oublier de bloquer la plage de recherche $A:$A

En tous cas la formule marche sur mon Excel 2013 et au moins là le nombre se modifie automatiquement à chaque rajout. 

Bonnes fêtes de fin d'année

Cordialement

0
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 74
30 déc. 2022 à 08:05

Bonjour

Il y a du progrès puisque maintenant j'obtiens un chiffre. Mais ce n'est pas le bon...

Comme vous pouvez le voir ici : https://ibb.co/16r3GYD

J'ai "17:00-03-00" 4 fois dans la feuille "shift"

Mais dans la feuille "total" : https://ibb.co/Krhbf6j le chiffre ne change pas . J'ai essayé avec $A:$A mais sans succès.

Merci pour votre aide.

0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
PapyLuc51 Messages postés 4238 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 22 février 2024 1 378
Modifié le 30 déc. 2022 à 09:24

Avec les bonnes colonnes et cellules (même si c'est une image) on peut arriver a faire quelque chose

En C3 du feuillet total mettre cette formule =NB.SI(shift!$B:$B;B3) formule à incrémenter vers le bas

Normalement ça devrait fonctionner ; si problème déposer une copie anonymisée de fichier sur https://www.cjoint.com/ ; créer le lien en bas de page, sur la nouvelle page, faire un clic droit sur le lien et cliquer sur copier l'adresse du lien ; venir le coller dans la réponse.

En revoyant ton feuillet shift tu ne vas avoir que les weekends inscrits sur la colonne B ; pour avoir tous l'ensemble il te faudra modifier la zone de recherche dans la formule : =NB.SI(shift!$B:$E;B3) mais si tu veux ça mois par mois je pense qu'il va falloir faire des modifications ; alors envoie le fichier et décris comment tu vois les choses.

À te lire

Cordialement

0
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 74
30 déc. 2022 à 15:00

Voici l'adresse du lien 

https://www.cjoint.com/c/LLEn6ZyRu5I

j'ai essayé ce que tu as conseillé mais ça n'a pas marché.

0
jee pee Messages postés 39297 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 22 février 2024 9 184
30 déc. 2022 à 12:08

Oui avec le fichier ce serait plus facile à tester. Sur tes images (que tu pourrais directement déposer sur le forum dans ton message avec l’icône paysage), on voit que tu es sur un téléphone, c'est de l'Excel sur mobile ?


0
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 74
30 déc. 2022 à 15:01

Le lien est en haut, oui c'est excel mobile.

0
bigoudiii Messages postés 195 Date d'inscription lundi 19 décembre 2022 Statut Membre Dernière intervention 21 février 2024 71
30 déc. 2022 à 16:03

hello,

ta formule doit porter sur la colonne B et pas la colonne A !!!

=NB.SI(shift!B:B;B6)

0
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 74
30 déc. 2022 à 16:19

Merci beaucoup pour votre aide . Je ne comprenais vraiment pas pourquoi ça ne marchait pas. 

0
PapyLuc51 Messages postés 4238 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 22 février 2024 1 378
30 déc. 2022 à 16:52

Tu ne donnes pas de commentaires sur l'esquisse que j'ai faite - si le tableau t'intéresse j'ai ajouté une ligne au bas du tableau shift pour afficher une 53ème semaine au cas ou l'année en comportait une (2026 par exemple). Je le garde à ta disposition.

Cordialement 

0
totomann Messages postés 739 Date d'inscription jeudi 11 mars 2010 Statut Membre Dernière intervention 30 décembre 2022 74 > PapyLuc51 Messages postés 4238 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 22 février 2024
30 déc. 2022 à 17:15

Pardon pour le manque de commentaires. Je te remercie pour l'effort fourni cependant ce tableau me semble plus difficile a lire. Mais si jamais j'ai besoin de plus amples détails pour les informations recommandé je ne manquerais pas de m'en inspirer. Encore une fois merci pour ton aide et le temps mis à disposition pour mon problème.

Cordialement 

0