Problème au boot après re-install

Résolu
Le Gardian Messages postés 356 Date d'inscription mardi 11 septembre 2007 Statut Membre Dernière intervention 5 novembre 2022 - Modifié le 2 nov. 2022 à 15:43
mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 - 7 nov. 2022 à 12:32

Bonjour,

J'ai un problème au démarrage après réinstallation de Debian Bullseye

Partitionnement:

  • sda1, sda2 : Win7
  • sda3 : Données communes
  • sda5 : bullseye (réinstallation)
  • sda6 : buster

Erreur :

Gave up waiting for root file system device. Common problems:
- Boot args (cat/proc/modules cmd lines)
- Check root delay =(did the systemwait lond enough?
- Missing modules (cat/proc/modules; ls/device
Alert UUID b5f-f950-4155-87209- 2d76794680 f4 does not exist. Dropping to the shell
Bus g Box v1.30 (debian 1:1.30.1-6 + b3) built in shell

L'installation initiale avait bien fonctionné sur "sda5".
Puis installation OK de "BUSTER" sur "sda6".
J'ai réinstallé car j'avais des problème d'installation avec certains paquets

Une idée?

Merci.


A voir également:

5 réponses

Bonjour,

Alert UUID b5f-f950-4155-87209- 2d76794680 f4 does not exist.


Ton fichier /etc/fstab fait référence à une partition qui n'existe pas. L'installation a dû modifier l'UUID d'une partition. Il faut corriger le fichier /etc/fstab.

L'UUID d'une partition c'est l'identifiant de cette partition.

1
mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 7 542
2 nov. 2022 à 15:53

Bonjour,

Je pense que ce sont plutôt les UUIDs dans grub qui sont incorrects. Pour corriger le problème, deux méthodes équivalentes :

  • soit tu utilises boot-repair
  • soit tu fais ce que fait boot-repair à la main à l'aide un live USB/CD (voir ce message).

Pendant que tu es chrooté, tu peux contrôler /etc/fstab et vérifier que les UUIDs correspondent bien au résultat de :

ls -l /dev/disk/by-uuid

Bonne chance

1
Le Gardian Messages postés 356 Date d'inscription mardi 11 septembre 2007 Statut Membre Dernière intervention 5 novembre 2022 32
30 oct. 2022 à 09:33

Ha! OK.

Je regarde cela.

Merci


0
Le Gardian Messages postés 356 Date d'inscription mardi 11 septembre 2007 Statut Membre Dernière intervention 5 novembre 2022 32
5 nov. 2022 à 14:29

Bonjour,

Oui, c'est incorrect. Je vais tenter de corriger avec "boot-repair".
Merci.


0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 7 542
7 nov. 2022 à 12:32

Bonjour,

Au besoin tu peux aussi corriger l'entrée invalide en corrigeant l'UUID incorrect dans grub. Pour éditer une entrée de menu, il faut utiliser la touche e. Tu peux utiliser soit l'UUID, soit l'identifiant de disque (e.g. (hd0, 0) pour /dev/sda1). Il faut donc que tu notes l'UUID quelque part. Plus de détails ici.

Si tu parviens à démarrer ainsi il ne te restera plus qu'à lancer sudo update-grub une fois que tu auras démarrer.

Bonne chance

0