Formule texte a mettre sous excel

Résolu/Fermé
larmiche Messages postés 19 Date d'inscription mercredi 15 mai 2019 Statut Membre Dernière intervention 1 mars 2024 - 3 oct. 2022 à 16:10
Mazzaropi Messages postés 1985 Date d'inscription lundi 16 août 2010 Statut Contributeur Dernière intervention 24 mai 2023 - 3 oct. 2022 à 17:07

Bonjour,

J'aimerais faciliter la comparaison de cellules dans mon tableau. J'ai déjà ma formule en tête mais je n'arrive pas a la transposer dans excel.

si l'une des cellules (B1 a D1) contiennent le "texte1" alors "texte2" sinon "texte3".

Pouvez-vous m'aider ?

En vous remerciant.


Windows / Firefox 105.0

A voir également:

4 réponses

ccm81 Messages postés 10824 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 29 février 2024 2 400
3 oct. 2022 à 16:35

Bonjour

Peut être ceci

=SI(ESTNA(EQUIV("texte 1";A1:D1;0));"texte 3";"texte2")

Cdlmnt

2
Mazzaropi Messages postés 1985 Date d'inscription lundi 16 août 2010 Statut Contributeur Dernière intervention 24 mai 2023 70
3 oct. 2022 à 16:39

larmiche, Bonjour.


Vérifiez si cette formule vous aide :

French:  

=SI( NB.SI(B1:D1; "texte1"); "texte2"; "texte3" )

English:

=IF( COUNTIF(B1:D1; "texte1"); "texte2"; "texte3" )

Utilisez le séparateur ";" ou "," selon votre version d'excel.

S'il vous plaît laissez-nous savoir si c'est ce que vous vouliez.

J'espère que j'ai aidé.

Cordialement.


2
larmiche Messages postés 19 Date d'inscription mercredi 15 mai 2019 Statut Membre Dernière intervention 1 mars 2024 1
3 oct. 2022 à 16:54

Bonjour,

Vos deux formules marchent. Et comme j'ai deux feuilles a comparer, elles auront chacune la leur pour pas faire de jaloux. ☺

En tous cas merci pour votre expertise, cela va me faire gagner un temps précieux.

Bonne journée !

0
Mazzaropi Messages postés 1985 Date d'inscription lundi 16 août 2010 Statut Contributeur Dernière intervention 24 mai 2023 70
3 oct. 2022 à 17:07

larmiche,

Merci pour les commentaires.

Je suis content de t'avoir aidé.

Bonne journée à toi.

Cordialement.


0