Attribution d'une valeur texte en fonction de valeur numérique d'une autre cellu

Signaler
Messages postés
3
Date d'inscription
vendredi 16 juillet 2021
Statut
Membre
Dernière intervention
19 juillet 2021
-
Messages postés
3
Date d'inscription
vendredi 16 juillet 2021
Statut
Membre
Dernière intervention
19 juillet 2021
-
Bonjour,

dans une colonne A j'ai un chiffre qui correspond à un nombre de jours.
En fonction de nombre de jours, je souhaite attribuer un texte selon les critères ci-dessous à la colonne B
Si A1 inférieure à 0 alors libellé B1 : En cours
Si A1 comprise entre 0 et 89 libellé B1 : Echu moins de 3 mois
Si A1 comprise entre 90 et 180 libellé B1 Echu 3 à 6 mois
Si A1 comprise entre 181 et 364 libellé B1 : Echu plus de 6 mois
Si A1 supérieure ou égale à 365 libellé B1 : Echu plus d'un an

Merci pour votre aide précieuse



Configuration: Windows / Edge 91.0.864.67

3 réponses

Messages postés
13057
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 juillet 2021
2 217
Bonjour

en B1:
=SI(A1<0;"En cours";SI(A1<90;"Echu moins 3 mois";SI(A1<181;"Echu 3 à 6 mois";SI(A1<365;"Echu plus 6 mois";"Echu plus d'un an"))))

Cdlmnt
Via
Messages postés
3
Date d'inscription
vendredi 16 juillet 2021
Statut
Membre
Dernière intervention
19 juillet 2021

Bonjour et merci,
Après test, il y a un problème
Pour une donnée de 1145 en A1 par exemple
ca me donne échu moins de 3 mois, il doit y avoir une petite erreur ?
Messages postés
3
Date d'inscription
vendredi 16 juillet 2021
Statut
Membre
Dernière intervention
19 juillet 2021
>
Messages postés
3
Date d'inscription
vendredi 16 juillet 2021
Statut
Membre
Dernière intervention
19 juillet 2021

re bonjour,
le problème venait de mon fichier, encore merci à tous et en particulier à via55 pour sa formule parfaite
Messages postés
9958
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 juillet 2021
2 161
Dans une conditionnelle de type si ... alors ... sinon
excel l'écrit comme ça
SI(condition;Instruction1;instruction2)
le premier ";" pour alors, le deuxième pour sinon

Pour ta formule (au passage voia55 n'a pas oublié)

=SI(A1<0;"msg0";A1<90;"msg1";SI(A1<=180;"msg2";SI(A1<365;"msg3";"msg4"))))

Si la première condition A1<0 n'est pas réalisée, c'est que A1 >= 0
de même si A1 <90 n'est pas réalisée, c'est que A1 >=90, etc ...
donc pas besoin de ET(A1>=;A1<=180)

Cdlmnt
J’essaye ça lundi, merci et bon we
Messages postés
9958
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 juillet 2021
2 161
Bonjour

=SI(A1<90;"msg1";SI(A1<=180;"msg2";SI(A1<365;"msg3";"msg4")))

Cdlmnt
Merci
Par contre quand il y a deux conditions du genre < 180 mais sup à 90 comment écrivez-vous cette formule ?