Attribution d'une valeur texte en fonction de valeur numérique d'une autre cellu

Fermé
Philgood91 Messages postés 3 Date d'inscription vendredi 16 juillet 2021 Statut Membre Dernière intervention 19 juillet 2021 - 16 juil. 2021 à 18:25
Philgood91 Messages postés 3 Date d'inscription vendredi 16 juillet 2021 Statut Membre Dernière intervention 19 juillet 2021 - 19 juil. 2021 à 10:28
Bonjour,

dans une colonne A j'ai un chiffre qui correspond à un nombre de jours.
En fonction de nombre de jours, je souhaite attribuer un texte selon les critères ci-dessous à la colonne B
Si A1 inférieure à 0 alors libellé B1 : En cours
Si A1 comprise entre 0 et 89 libellé B1 : Echu moins de 3 mois
Si A1 comprise entre 90 et 180 libellé B1 Echu 3 à 6 mois
Si A1 comprise entre 181 et 364 libellé B1 : Echu plus de 6 mois
Si A1 supérieure ou égale à 365 libellé B1 : Echu plus d'un an

Merci pour votre aide précieuse



Configuration: Windows / Edge 91.0.864.67

3 réponses

via55 Messages postés 13888 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 3 octobre 2022 2 490
16 juil. 2021 à 18:41
Bonjour

en B1:
=SI(A1<0;"En cours";SI(A1<90;"Echu moins 3 mois";SI(A1<181;"Echu 3 à 6 mois";SI(A1<365;"Echu plus 6 mois";"Echu plus d'un an"))))

Cdlmnt
Via
1
Philgood91 Messages postés 3 Date d'inscription vendredi 16 juillet 2021 Statut Membre Dernière intervention 19 juillet 2021
19 juil. 2021 à 09:51
Bonjour et merci,
Après test, il y a un problème
Pour une donnée de 1145 en A1 par exemple
ca me donne échu moins de 3 mois, il doit y avoir une petite erreur ?
0
Philgood91 Messages postés 3 Date d'inscription vendredi 16 juillet 2021 Statut Membre Dernière intervention 19 juillet 2021 > Philgood91 Messages postés 3 Date d'inscription vendredi 16 juillet 2021 Statut Membre Dernière intervention 19 juillet 2021
19 juil. 2021 à 10:28
re bonjour,
le problème venait de mon fichier, encore merci à tous et en particulier à via55 pour sa formule parfaite
0
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
16 juil. 2021 à 20:06
Dans une conditionnelle de type si ... alors ... sinon
excel l'écrit comme ça
SI(condition;Instruction1;instruction2)
le premier ";" pour alors, le deuxième pour sinon

Pour ta formule (au passage voia55 n'a pas oublié)

=SI(A1<0;"msg0";A1<90;"msg1";SI(A1<=180;"msg2";SI(A1<365;"msg3";"msg4"))))

Si la première condition A1<0 n'est pas réalisée, c'est que A1 >= 0
de même si A1 <90 n'est pas réalisée, c'est que A1 >=90, etc ...
donc pas besoin de ET(A1>=;A1<=180)

Cdlmnt
1
J’essaye ça lundi, merci et bon we
0
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
16 juil. 2021 à 18:40
Bonjour

=SI(A1<90;"msg1";SI(A1<=180;"msg2";SI(A1<365;"msg3";"msg4")))

Cdlmnt
0
Merci
Par contre quand il y a deux conditions du genre < 180 mais sup à 90 comment écrivez-vous cette formule ?
0