Effectuer une somme si sur le jour d'une date [Résolu]

Signaler
Messages postés
4
Date d'inscription
dimanche 16 mai 2021
Statut
Membre
Dernière intervention
16 mai 2021
-
Messages postés
4
Date d'inscription
dimanche 16 mai 2021
Statut
Membre
Dernière intervention
16 mai 2021
-
Bonjour les CCM !
Petite question qui me fait des nœuds au cerveau depuis 3 jours :

Je souhaite faire un "somme.si" dont le critère est basé sur le jour de la date.
J'ai ce genre de chose :
Date Valeur
05/02/2012 13
06/03/2015 11
08/05/2016 31
12/05/2016 52
13/01/2017 33
06/08/2017 5
31/08/2017 17
06/12/2017 95

Je veux savoir combien j'ai au total le 6 du mois par exemple : Ici 11+5+95 sans avoir à créer une nouvelle colonne de type =jour(A1) etc puis aller chercher le critère "6" dans cette nouvelle colonne avec un somme.si


J'ai bien essayé de faire quelque chose de ce genre : =somme.si(A:A;"06/*";B:B) mais avec les dates ce genre de chose ne fonctionne pas pour aller chercher un jour précisément. Avez-vous une idée svp ?


Merci beaucoup !!!

2 réponses

Messages postés
699
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
9 juin 2021
53
Bonjour,
=SOMMEPROD((JOUR(A2:A9)=6)*(B2:B9))

Cordialement
Messages postés
4
Date d'inscription
dimanche 16 mai 2021
Statut
Membre
Dernière intervention
16 mai 2021

Mille mercis ALS35 !! J'avais essayé avec cette fonction mais je pense que je ne la comprends pas très bien. En effet, il faut prendre la matrice du jour 6 !!! J'ai 100 nœuds de défaits aujourd'hui :)
Messages postés
699
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
9 juin 2021
53 >
Messages postés
4
Date d'inscription
dimanche 16 mai 2021
Statut
Membre
Dernière intervention
16 mai 2021

JOUR(A2:A9)=6 est une fonction matricielle qui renvoie VRAI ou FAUX (converti en 1 ou 0 dans les calculs) pour chaque valeur de la plage A2:A9, que l'on multiplie ensuite par chaque valeur de la plage B2:B9. La fonction SOMMEPROD fait la somme de l'ensemble de ces produits

Cordialement
Messages postés
4
Date d'inscription
dimanche 16 mai 2021
Statut
Membre
Dernière intervention
16 mai 2021
>
Messages postés
699
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
9 juin 2021

Génial !! En effet la conversion en 1/0 est salvatrice ! Merci pour l'info !
Messages postés
26066
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 juin 2021
5 958
Bonsoir
SOMME.SI ne fonctionnera pas:
exemple pour un champ de date A2:A100, montant B2:B100 date:6 du mois:
=SOMMEPROD((JOUR(A2:A100)=6)*(B2:B100))
et pour info, le cumul de tous les lundis:
=SOMMEPROD((JOURSEM(A2:A100;2)=1)*(B2:B100))
=1 pour lundi, 2 pour mardi etc>...
crdlmnt
Messages postés
4
Date d'inscription
dimanche 16 mai 2021
Statut
Membre
Dernière intervention
16 mai 2021

Merci pour l'info supplémentaire qui j'espère servira à tous ceux qui auront eu ce problème similaire !