Formule si

Signaler
-
Messages postés
706
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
24 juillet 2021
-
Bonjour,

Je cherche une formule me permettant de trouver une valeur en fonction de la date
si la date de ma facture est comprise entre la date du JJ/MM/AAAA et du JJ/MM/AAAA alors ma cellule egal un montant etc. J'ai essayé de faire ca mais ca me met #valeur

=SI(ET(I5>=DATEVAL(2017/8/10);I5<=DATEVAL(2018/12/27));"240,78";SI(ET(I5>=DATEVAL(2018/12/28);I5<=DATEVAL(2019/8/1));"243,19";SI(ET(I5>=DATEVAL(2019/8/2);I5<=DATEVAL(2020/8/2));"244,78";SI(ET(I5>=DATEVAL(2020/8/3);I5<=DATEVAL(2021/8/31));"246,47";"MAJ ARRETE"))))

Auriez vous une solution pour moi ?

Bien cordialement.

jeremy



Configuration: Windows / Chrome 90.0.4430.93

1 réponse

Messages postés
17419
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 juillet 2021
4 671
Bonjour,

dans ta formule place tes dates entre guillemets, pas tes valeurs

=SI(ET(I5>=DATEVAL("2017/8/10");I5<=DATEVAL("2018/12/27"));240,78;etc .....)

=SI(ET(I5>=DATEVAL("2017/8/10");I5<=DATEVAL("2018/12/27"));240,78;etc .....)

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
merci beaucoup.
Messages postés
706
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
24 juillet 2021
53 > jeremy4681
Bonjour à tous,

Tu peux aussi raccourcir ta formule sans fonction ET comme ceci :
=SI(I5>=DATEVAL("2017/8/10");SI(I5<=DATEVAL("2018/12/27");240,78;SI(I5<=DATEVAL("2019/8/1");243,19;SI(I5<=DATEVAL("2020/8/2");244,78;SI(I5<=DATEVAL("2021/8/31");246,47;"MAJ ARRETE")))))


Cordialement