Sommeprod si cellules non vides [Résolu]

Signaler
-
 Luc -
Bonjour,

Je me permets de demander votre aide à propos d'une formule Excel qui dépasse mes compétences.

Dans la cellule H4, j'ai calculé la somme moyenne investie tous formats confondus à l'aide de la formule suivante: =SOMMEPROD(C:C;E:E)/SOMME(E:E)
Dans la cellule H6, je souhaite calculer la somme moyenne investie uniquement pour le format 1, c'est à dire seulement quand il y a une valeur dans la colonne A.
J'ai donc besoin d'utiliser une formule similaire à celle ci-dessus mais qui fait le calcul uniquement quand les cellules de la colonne A ne sont pas vides.

Désolé si mes explications ne sont pas assez claires mais je pense que vous devriez comprendre grâce au fichier ci-joint.
https://www.cjoint.com/c/KEcdkA3wyNv

Merci d'avance.


Configuration: Macintosh / Chrome 90.0.4430.85

1 réponse

Messages postés
17343
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 mai 2021
4 601
Bonjour,

D'après ce que je comprends, regarde comme cela

=SOMMEPROD(C:C;E:E)/SOMMEPROD((E2:E30)*(A2:A30<>""))
Bonsoir,

Je me suis rendu compte au final que cette formule donne un résultat erroné mais merci tout de même.
Celle-ci fonctionne par contre : =SOMMEPROD((C2:C21)*(E2:E21)*(A2:A21<>""))/SOMMEPROD((A2:A21<>"")*(E2:E21))