Récupérer les valeurs d'un 2ème onglet quand il n'y a plus de valeur dans le 1er [Résolu]

Signaler
Messages postés
147
Date d'inscription
mardi 6 mars 2018
Statut
Membre
Dernière intervention
3 mai 2021
-
Messages postés
53799
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 mai 2021
-
Bonjour,

Je souhaite récupérer les valeurs de deux onglets séparés dans un onglet que j'ai appelé synthèse. L'idée est de récupérer toutes valeurs du premier onglet en priorité et puis quand ça arrive à la fin et qu'il n'y a plus de valeurs dans le premier onglet je récupère les valeurs qui sont dans le deuxième onglet.

Je ne sais pas si ce que je dis est clair mais voici le lien du fichier pour illustrer mon problème.

https://mon-partage.fr/f/pe8lecGU/

Auriez vous une astuce pour me dépanner ?

Merci beaucoup par avance

Bonne journée

Configuration: Windows / Chrome 90.0.4430.93

4 réponses

Messages postés
53799
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 mai 2021
15 812
Mais ... tu as déjà résolu ton problème ! Que demandes-tu de plus ?
Messages postés
147
Date d'inscription
mardi 6 mars 2018
Statut
Membre
Dernière intervention
3 mai 2021
1
Merci beaucoup :-)
Messages postés
3174
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
4 mai 2021
442
Bonjour à tous,

une proposition

https://www.cjoint.com/c/KEbrLrFfRgi


Crdlmt
Messages postés
147
Date d'inscription
mardi 6 mars 2018
Statut
Membre
Dernière intervention
3 mai 2021
1
Merci beaucoup ;-)
Messages postés
9954
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
4 mai 2021
1 138
Bonjour,
juste au passage une solution (voir plage bleutée.
Le lien:https://mon-partage.fr/f/KZf1WhT0/

Salutations.
Le Pingou
Messages postés
147
Date d'inscription
mardi 6 mars 2018
Statut
Membre
Dernière intervention
3 mai 2021
1
Merci beaucoup :-)
Messages postés
53799
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 mai 2021
15 812
Bonjour Sayro.
Tu as dit merci à Le Pingou , à DjiDji ainsi qu'à moi, hier ; mais finalement, quelle formule as-tu adoptée ?

=SI('Ile de France'!B2<>"";'Ile de France'!B2;INDIRECT("Annexe!b"&LIGNE('Ile de France'!B2)-NBVAL('Ile de France'!B:B)+1))

=SIERREUR(RECHERCHEV(A2;'Ile de France'!$A$2:$B$10;2;0);RECHERCHEV(A2;Annexe!$A$2:$B$5;2;0))

=SI('Ile de France'!B2="";Annexe!B2;'Ile de France'!B2)