Récupérer les valeurs d'un 2ème onglet quand il n'y a plus de valeur dans le 1er

Résolu/Fermé
SAYRO Messages postés 156 Date d'inscription mardi 6 mars 2018 Statut Membre Dernière intervention 7 septembre 2022 - Modifié le 1 mai 2021 à 18:06
Raymond PENTIER Messages postés 57001 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 4 février 2023 - 4 mai 2021 à 18:19
Bonjour,

Je souhaite récupérer les valeurs de deux onglets séparés dans un onglet que j'ai appelé synthèse. L'idée est de récupérer toutes valeurs du premier onglet en priorité et puis quand ça arrive à la fin et qu'il n'y a plus de valeurs dans le premier onglet je récupère les valeurs qui sont dans le deuxième onglet.

Je ne sais pas si ce que je dis est clair mais voici le lien du fichier pour illustrer mon problème.

https://mon-partage.fr/f/pe8lecGU/

Auriez vous une astuce pour me dépanner ?

Merci beaucoup par avance

Bonne journée

Configuration: Windows / Chrome 90.0.4430.93

4 réponses

Raymond PENTIER Messages postés 57001 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 4 février 2023 17 169
1 mai 2021 à 19:22
Mais ... tu as déjà résolu ton problème ! Que demandes-tu de plus ?
1
SAYRO Messages postés 156 Date d'inscription mardi 6 mars 2018 Statut Membre Dernière intervention 7 septembre 2022 2
3 mai 2021 à 22:35
Merci beaucoup :-)
0
DjiDji59430 Messages postés 3734 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 1 février 2023 571
1 mai 2021 à 19:37
Bonjour à tous,

une proposition

https://www.cjoint.com/c/KEbrLrFfRgi


Crdlmt
1
SAYRO Messages postés 156 Date d'inscription mardi 6 mars 2018 Statut Membre Dernière intervention 7 septembre 2022 2
3 mai 2021 à 22:35
Merci beaucoup ;-)
0
Le Pingou Messages postés 11432 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 4 février 2023 1 331
Modifié le 1 mai 2021 à 22:15
Bonjour,
juste au passage une solution (voir plage bleutée.
Le lien:https://mon-partage.fr/f/KZf1WhT0/

Salutations.
Le Pingou
1
SAYRO Messages postés 156 Date d'inscription mardi 6 mars 2018 Statut Membre Dernière intervention 7 septembre 2022 2
3 mai 2021 à 22:35
Merci beaucoup :-)
0
Raymond PENTIER Messages postés 57001 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 4 février 2023 17 169
4 mai 2021 à 18:19
Bonjour Sayro.
Tu as dit merci à Le Pingou , à DjiDji ainsi qu'à moi, hier ; mais finalement, quelle formule as-tu adoptée ?

=SI('Ile de France'!B2<>"";'Ile de France'!B2;INDIRECT("Annexe!b"&LIGNE('Ile de France'!B2)-NBVAL('Ile de France'!B:B)+1))

=SIERREUR(RECHERCHEV(A2;'Ile de France'!$A$2:$B$10;2;0);RECHERCHEV(A2;Annexe!$A$2:$B$5;2;0))

=SI('Ile de France'!B2="";Annexe!B2;'Ile de France'!B2)

0