Formule heures entre 2 dates

Résolu/Fermé
Mar1_ Messages postés 5 Date d'inscription mardi 27 avril 2021 Statut Membre Dernière intervention 28 avril 2021 - 27 avril 2021 à 01:29
Mar1_ Messages postés 5 Date d'inscription mardi 27 avril 2021 Statut Membre Dernière intervention 28 avril 2021 - 28 avril 2021 à 11:19
Bonjour,

Je veux calculer le nombre d'heure entre deux date/heures différentes en tenant compte que le service commence à 09h et termine à 18h. à ne pas inclure les heures entre 18h et 09h.
NB: Format date/heure que j'ai ==> 23/04/2021 09:33
Ex: les heures entre 22/04/2021 09:00 et 25/04/2021 10:00
C'est quoi la formule pour avoir les 28 heures d'écart? Merci d'avance
A voir également:

4 réponses

PapyLuc51 Messages postés 3805 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 4 décembre 2022 1 198
Modifié le 27 avril 2021 à 05:58
Bonjour,

Une proposition

A1=Début
B1=Fin

cellule réceptrice au format [hh]:mm

=B1-A1-(JOURS(B1;A1)*15/24)


15 étant le nombre d'heures à retirer par journée

Cordialement
0
Mar1_ Messages postés 5 Date d'inscription mardi 27 avril 2021 Statut Membre Dernière intervention 28 avril 2021
27 avril 2021 à 12:05
Merci infiniment, ça répond partiellement à ma question. si je reçois un acte avant 09h00 qui est l'heure d'ouverture, le compteur ne doit commencer qu'à partir de 09h. Y a t-il une formule pour ça?
0
PapyLuc51 Messages postés 3805 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 4 décembre 2022 1 198
27 avril 2021 à 12:12
Précise un peu plus ta demande et envoie un bout de ton fichier avec des exemples de résultats attendus

Aller dans https://www.cjoint.com/
Cliquer sur "PARCOURIR" pour sélectionner le classeur ou "FAIRE UN GLISSER DEPOSER" dans la fenêtre ;
Cliquer sur le bouton "CREER LE LIEN"
Faire un "CLIC DROIT" sur le lien créé "COPIER L'ADRESSE DU LIEN" ;
Sur le post Clic droit "COLLER".

ou dans https://mon-partage.fr/

Cordialement
0
Mar1_ Messages postés 5 Date d'inscription mardi 27 avril 2021 Statut Membre Dernière intervention 28 avril 2021
Modifié le 27 avril 2021 à 14:42
https://www.cjoint.com/c/KDBmPOpRn5f
l'activité de lundi à dimanche
0
PapyLuc51 Messages postés 3805 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 4 décembre 2022 1 198
27 avril 2021 à 14:52
la fin ne peut pas être au delà de 19h00 je suppose !!

Cordialement
0
Mar1_ Messages postés 5 Date d'inscription mardi 27 avril 2021 Statut Membre Dernière intervention 28 avril 2021
27 avril 2021 à 15:17
la plage horaire de travail et de traitement est de 09h à 18h
0
PapyLuc51 Messages postés 3805 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 4 décembre 2022 1 198
28 avril 2021 à 06:26
Bonjour,

Dans 3 cellules à part

•Heure de début = 09:00 cellule nommée HreDeb
•Heure de fin = 18:00 cellule nommée HreFin
•Journée complète = 09:00 cellule nommée JourEnt

En C2 cette formule

=SI(ENT(A2)=ENT(B2);B2-ENT(B2)-SI(A2-ENT(A2)<HreDeb;HreDeb;A2-ENT(A2));SI(ENT(B2)-ENT(A2)=1;B2-ENT(B2)-HreDeb+HreFin-SI(A2-ENT(A2)<HreDeb;HreDeb;A2-ENT(A2));SI(ENT(B2)-ENT(A2)>1;B2-ENT(B2)-HreDeb+HreFin-SI(A2-ENT(A2)<HreDeb;HreDeb;A2-ENT(A2))+(ENT(B2)-1-ENT(A2))*JourEnt;"")))


https://www.cjoint.com/c/KDCev2cvBgp

Cordialement
0
PapyLuc51 Messages postés 3805 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 4 décembre 2022 1 198
28 avril 2021 à 08:44
Même formule en plus court

=SI(ENT(A2)=ENT(B2);B2-ENT(B2)-SI(A2-ENT(A2)<HreDeb;HreDeb;A2-ENT(A2));SI(ENT(B2)-ENT(A2)=1;B2-ENT(B2)-HreDeb+HreFin-SI(A2-ENT(A2)<HreDeb;HreDeb;A2-ENT(A2));B2-ENT(B2)-HreDeb+HreFin-SI(A2-ENT(A2)<HreDeb;HreDeb;A2-ENT(A2))+(ENT(B2)-1-ENT(A2))*JourEnt))


Cordialement
0
Mar1_ Messages postés 5 Date d'inscription mardi 27 avril 2021 Statut Membre Dernière intervention 28 avril 2021
28 avril 2021 à 11:19
Bonjour,

Merci beaucoup. ça marche
Merci infiniment
0