Attribuer un prix en fonction d'un actif [Résolu]

Signaler
-
 saintvit -
Bonjour,

Sur une feuille 1 excel , via des APY , j'ai mis le prix actuel de plusieurs actifs en bourse et classés selon le volume d'échange ( TOP10).

Donc par exemple :

Colonne A : Nom Colonne B : Symbole Colonne C : Prix

1) Or XAU 47.000$
2) Argent XAG 25$
3) Platine Platinium 1181$

Maintenant , sur une autre feuille 2 , j'aimerais qu'en inscrivant " Argent" dans la colonne A , le prix s'inscris automatiquement dans la colonne B ( 25$). Par contre , je ne peux pas attribuer sur la feuille 2, pour le prix ( ='Feuil1'!C2) parce'que si l'argent s'échange moins que le Platine , celui-ci passera en 3 ème position donc en C3).

En bref , je voudrais attribuer un prix en fonction d'un actif via une base de donnée qui se trouve sur une autre feuille .

J'espère avoir été clair ,

Merci d'avance pour votre aide :)

1 réponse

Messages postés
17371
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
11 juin 2021
4 638
Bonjour,

le principe est

=RECHERCHEV(Feuil2!A2;Feuil1!A2:D20;3;0)

tu peux simplifier la formule en nommant les plages, exemple Feuil1!A2:D20 ou se trouvent tes données, si tu la nommes par exemple List, la formule devient

=RECHERCHEV(Feuil2!A2;List;3;0)

et même plus simple
=RECHERCHEV(A2;List;3;0)
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Merci beaucoup pour la formule , cela fonctionne ! :)

Bonne fin de journée