=SOMME.SI.ENS (TEXTE + DATE) EXCLE 2007 [Résolu]

Signaler
Messages postés
36
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
27 février 2021
-
Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
-
Bonjour mes ami(e)s,

Je suis à la recherche de la formule =somme.si.ens avec des critères de recherche par exemple des toutes les cellules contenant un texte défini qui compris entre 2 dates différentes.

Merci de votre aimable réponse.

11 réponses

Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 797
Bonjour
difficile de vous aider sans connaître vos données
pour le principe:
=SOMME.SI.ENS(champ à sommer; champ texte;"texte"; champ date;">="&cell1 mini;champ date;"<="&Cell maxi)
avec bien sur les dates limites en cell1 et 2
et si ça ne va pas, déposez un modèle, même bidonné, ici par exemple:
https://mon-partage.fr
et revenez coller le lien créé sur le site
à vous lire
crdlmnt
Messages postés
36
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
27 février 2021

Bonjour, je cherche par exemple le total des montants de TVA 20% entre 2 dates du 17/02/2021au 20/02/2021

https://mon-partage.fr/f/kZhJTQue/
Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 797
à défaut d'in formation sur le fichier:
dates en colonne A
taux en colonne B
montant en colonne c
en D1: taux cherché (exemple: 20%)
en D2 date mini
end D3 date max
mais on ne sait pas avec ça s'il s'agit des montants de la TVA ou de ceux des valeurs permettant de la calculer
1° cas il s'agit des montants de TVA
=SOMME.SI.ENS(C:C;B:B;D1;A:A;">="&D2;A:A;"<="&D3)
2° cas: s'il s'agit de calculer la TVA sur le total des 20%
=SOMME.SI.ENS(C:C;B:B;D1;A:A;">="&D2;A:A;"<="&D3)*D3
crdlmnt



Date ne colonne a
Messages postés
36
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
27 février 2021

Désolé, je me suis mal exprimé, je cherche le total des montants qui ont une de TVA 20% entre 2 dates du 17/02/2021au 20/02/2021.

Merci.
Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 797
Et donc?
pour appliquer la formule, par exemple en D4
entrez 20% en D1 (à condition que la valeur soit bien numérique et pas texte)
entrez 17/02/2021 en D2
entrez 20/02/2021 en D3
mais il faut bien entendu que vos données dates et taux soient bien numériques dans la plage à traiter, et ça on ne peut pas savoir sans votre modèle, l'image ne suffit pas
voyez ici et examinez bien les formats de cellules
https://mon-partage.fr/f/vLOR1IUw/



Messages postés
36
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
27 février 2021

Et si la recherche concerne du TEXTE au lieu des données numériques en entre deux dates ? quelle serait alors la formule à appliquer dans ce cas précis ?
Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 797
Vous ne pouvez pas sommer des données non numériques, s'il s'agit de la colonne C de mob exemple
si la colonne B(le taux) contient des textes (c'est dommage alors que le format de cellule permet d'afficher 20% en entrant 20), et donc le signe % est entré au clavier, faite de même en D11 dans un format texte et ça fonctionne
voyez ici avec D1 et B:B en format texte
https://mon-partage.fr/f/SzqseyFZ/
S'il s'agit de la colonne montant en texte à cause du USD, vous pouvez traiter ça avec trois opérations en sélectionnant la colonne où le champ repli:
1° touche ctrl et touche h ensemble
dans la fenêtre affichée: remplacer: entrez USD
par: ne mettez rien et "remplacer tout". Cette opération va supprimer le texte
2° formatez comme mon premier modèle, copier une cellule vide hors champ, sélectionnez le champ de valeur et "collage spécial et "ajouter"
ceci va numériser vos résultat en conservant l'affichage USD
(fonctionne même s'il y a un blanc, ou non entre le montant et "USD"
.. peux pas dire mieux
crdlmnt

Messages postés
36
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
27 février 2021

Bonjour et merci infiniment pour tous les efforts que vous déployez pour me résoudre ce problème, j'ai toujours le problème quand j'applique la formule suivante qui me donne le chiffre O !!!!!
Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 797
Bonjour
si vous ne voulez pas utiliser de cellules comme dans mon modèle pour placer les dates, placez les aussi entre guillemets dans la formule pour qu'Excel puisse les identifier en tant que telles:
=SOMME.SI.ENS(C:C;A:A;"TVAACHAT10%";B:B;">="&"31/12/2O";B:B;"<="&"31/12/21")

notez aussi que dans votre formule, le premier >= dans le code va aussi inclure les dates du 31/12/2020 dans le total
crdlmnt

Messages postés
36
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
27 février 2021

Mille mercis de votre patience et vos explications qui ont donné leurs fruits.

Très bon début de semaine.
Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 797
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt