Calcul commission [Résolu]

Signaler
-
Messages postés
25860
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
-
Bonjour,

J'aimerai créer une formule SI dans un document Excel pour le calcul d'une commission mais mes années écoles sont assez loin.

Pour vous expliquer la complexité est le fait que la commission dépendra du CA HT cumulé selon la tranche (De 1€ a 70 000€, de 70 001€ à 110 000€, de 110 000€ à 140 000€ et au delà de 140 000€) et du fait de la provenance du client (Si le client vient de son réseau le % ne sera pas le même que si le client vient par l'entreprise)

Est ce que vous arrivez à me comprendre ?

Merci pour votre aide



Configuration: Windows / Chrome 88.0.4324.150

7 réponses

Messages postés
25860
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
5 812
Bonjour
à adapter
base de données en X1:Z5
  • en X1: "montants" de X2 à X6: 0 70000,1 110000,1 140000,1 1000000 ou plus selon ce qui risque de dépasser la limite 140000
  • en Y1: "% réseau " de Y2 à Y6 valeur du % réseau en commençant par le taux à -de 70000 en Y2 '<souligne>en face du 0)/souligne> etc..
  • en Z1: "%inter" et même chose pour le taux de % en cas d'origine interne
  • en A1 "nom" avec le nom à partir de A2
  • en B1 "origine" avec l'info 'interne" ou "réseau" à partir de B2
  • en C1: "montant"
  • en D1: "commission" avec à partir de D2 la formule:


=SIERREUR(B2*RECHERCHEV(B2;$X$2:$Y$6;SI(C2="interne";3;2));"")

à tirer sur la hauteur utile

la formule va chercher, dans la bonne colonne le taux correspondant à la tranche dont le maxi est indiqué en X
(soit de 0 à70000 en face du 0 par exemple)$
revenez si soucis mais avec plus d'infos sur vos données ou en déposant un fichier avec quelques explications par exemple ici:
https://mon-partage.fr et revenez coller le lien créé sur le site

crdlmnt



Merci pour le retour.

J'ai essayé de faire quelque chose, si vous pouvez jeter un coup d'oeil.

J'ai mis une petite annotation.

https://mon-partage.fr/f/3i8qKVxo/

Cordialement
Messages postés
3116
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
4 mars 2021
865
Bonjour,

Une esquisse à rectifier selon le tableau réel

https://www.cjoint.com/c/KBkqrZhC67k

Cordialement
Super merci,

Je vais l'adapter car j'aurai aimé l'avoir sur une page avec le cumul du CA, car chaque vente augmentera le CA et fera évoluer le % de commission.

Je ne sais pas si vous arrivez à me suivre
Voici un lien vers quelque chose que j'ai créé.

https://mon-partage.fr/f/3i8qKVxo/

Merci
Messages postés
25860
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
5 812
1°) pour quelles raisons la seconde vente de 56000 doit elle se placer dans la tranche au dessus de 70000?
si nous sommes d'accord sur le fait que vous partez de la valeur en F?
2°) si vous voulez inclure la limite dans la tranche supérieure, supprimer le 1 et remplacez par 0 dans le tableau en Q, la tranche s'affichera lorsque la valeur exacte sera atteinte
3°) placez cette formule un peu plus simple en H5:
=SI(F5="";"";SIERREUR(RECHERCHEV(F5;T_Rech;SI(G5="C_Réseau";2;3));""))
mais voyez si vous devez faire référence à Cou à F
à+
Je veux que la seconde vente soit dans la tranche au dessus de 70 000 car la commission se calcule sur le Ca cumulé par sur du one shoot.

Moi je veux que la commission se calcule sur la valeur D mais que la tranche soit calculée avec la colonne E.

Vous voyez mieux ?

Merci
Messages postés
25860
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
5 812
Ben... non
  • vu que votre formule cherche sur la colonne F ??????
  • que votre formule en E5 concerne tout le champ D, que devient elle en E6?
  • qu'il n'y a aucun montant dans votre tableau qui dépasse les 70000, sauf dans ce E dont on ne sait pas ce qu'il devient dans la suite du tableau
  • qu'il n'y a aucune affectation à C_entreprise

et donc qu'il n'y a aucune raison d'arriver à 20%, sauf si le 70000 est à inclure dans le plancher des 20% plutôt que dans le plafond des 15 de réseau

à moins que la formule en E puisse être SOMME($E$5:E5) et donc que l cumul est en conséquence le taux puisse évoluer en fonction du cumul évolutif de E

complétez les explications

Désolé je pense que je ne suis pas précis dans mes explications. On va oublier mon tableau test et je vais essayer de mieux m'exprimer.

Ce que je cherche à faire c'est à ce que le montant de la commission se calcule automatiquement. Cette commission est basée sur plusieurs éléments:
- Le montant de la commission de chaque vente
- Le pourcentage si le client vient du commercial ou de la société
- Le cumul du CA

En gros à chaque vente, le commercial touche un % de la commission (ce % évolue en fonction du CA cumulé au cours de l'année et de la provenance du client).

Imaginons ce cas de figure:
1er vente CA 20 000 - LE client vient de lui donc 15%
2nd vente CA 40 000 - Le client vient de la société donc 10%
3eme vente CA 30 000 - Le client vient de lui et son CA cumulé a changé de tranche car le CA cumulé a dépassé le premier stade de 70 000€ donc 20% mais sur la base de la commission de la vente (30 000)

Je me suis mieux expliqué ?
Messages postés
25860
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
5 812
je pense avoir compris effectivement.... ça reste à confirmer
voyez ici et revenez si ça ne convient pas!
https://mon-partage.fr/f/15lDb1FO/
Bonne soirée et à demain peut être
C'est exactement ça.

Merci beaucoup pour l'aide.

Bonne soirée
Bonjour,

Visiblement le souci dure toujours.

Je vous joins le tableau avec les annotations.

https://mon-partage.fr/f/qACurttD/

Merci
Messages postés
25860
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
5 812
?????? vous me renvoyez l'ancien modèle?
visiblement vous n'avez pas placé en colonne E la formule du modèle que je vous ai proposé?... pas plus qu'en H la formule continue à s'adresser à F au lieu de E
faites et revenez si soucis
à+
Toutes mes excuses je ne vous avais pas envoyé la bonne version.

Tout est ok.

Merci encore
Messages postés
25860
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 mars 2021
5 812
pas de problème
bonne route
crdlmnt