Ajout de caractère pour former une nouvelle cellule à partir de 2 autres [Résolu]

Signaler
-
Messages postés
2446
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
23 février 2021
-
Bonjour,
j'ai une cellule 20,200 et une autre cellule 21,050 et je souhaite ainsi former une troisième cellule dont le résultat doit être 20+0200 à 21+0050. et j'ai des centaines de ligne comme ceci à faire.
Merci de votre aide


Configuration: Windows / Chrome 86.0.4240.111

4 réponses

Messages postés
3076
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 février 2021
426
Bonjour,

Un fichier EXCEL (test ou non), complété par des explications exhaustives et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question.

Crdmt
Messages postés
31065
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 février 2021
7 410
Bonjour,

A essayer :
=TEXTE(A1;"0")&"+"&TEXTE((A1-ENT(A1))*1000;"0000")&" à "
&TEXTE(B1;"0")&"+"&TEXTE((B1-ENT(B1))*1000;"0000")


Merci beaucoup jee pee.
Cela fonctionne
Une bouée de sauvetage pour moi
Je me suis un peu trop emballé. La solution apportée par Jee Pee est approchante mais des erreurs sont apparues dans certaines cellules.
Fichier joint
https://www.cjoint.com/c/KBkpHQarmq3

Merci de votre aide
Messages postés
31065
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 février 2021
7 410
voir :
=TEXTE(ENT(B4);"0")&"+"&TEXTE((B4-ENT(B4))*1000;"0000")&" à "
&TEXTE(ENT(C4);"0")&"+"&TEXTE((C4-ENT(C4))*1000;"0000")
Messages postés
2446
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
23 février 2021
945
Bonjour,
Quelques difficultés liées à la formule en C.. et au format nombre.
Essayez:
=TEXTE(ENT(B4);"0")&"+"&SUBSTITUE(TEXTE(MOD(B4;1);"0,000");",";"")&" à "&TEXTE(ENT(C4);"0")&"+"&SUBSTITUE(TEXTE(MOD(C4;1);"0,000");",";"")