Calculer un montant en fonction d'une date [Résolu]

Signaler
-
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021
-
Bonjour à tous,

je rencontre un petit souci sur une formule, je souhaiterais pouvoir calculer une somme en fonction du mois

exemple :

dans la colonne A1:A40 j'ai des prix d'articles et dans la colonne B1:B40 j'ai des dates écrite sous format 08/02/21 et réécrite automatiquement en date longue soit : Lundi 08 Février 2021.
Dans la colonne B1:B40 j'ai plusieurs mois (janvier, février, mars etc...)

Je souhaiterais calculer dans une cellule C1 la somme des prix uniquement du mois de janvier ensuite dans une autre cellule C2 la somme des prix de février etc...

Quelle serait la bonne formue ?
En sachant que la réécriture automatique "date longue" ne me permet pas d'isoler le mot "*février*"


Merci d'avance pour votre aide.

2 réponses

Messages postés
3105
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 février 2021
862
Bonjour,

Si dans la colonne A les dates sont au format "date longue" inutile d'isoler le mois de cette façon ; il faut l'isoler avec son numéro 1 à 12.

Ou alors de C1 à C12 mettre les numéros des mois

En D1 cette formule à faire glisser jusqu'à D12

=SOMMEPROD((MOIS($A$1:$A$40)=C1)*($B$1:$B$40))


Cordialement
Messages postés
2
Date d'inscription
mardi 9 février 2021
Statut
Membre
Dernière intervention
16 février 2021

Bonjour,

Désoler mais avec cette formule ça ne fonctionne pas non plus ça m'affiche : 0

Pour bien comprendre si je reprends votre exemple :

La colonne "A" représente les mois (allons de la cellule 1 à 40)
La colonne "B" les Prix (allons également de la cellule 1 à 40)
Et la colonne "C", la colonne où je met le résultat des calcules. Exemple "C1" la somme total des prix pour le mois de janvier / "C2" la somme total des prix pour le mois de février ETC...

En oubliant toujours pas que les dates sont au format "date longue"

Merci d'essayer de m'éclairer.
Messages postés
3105
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 février 2021
862 >
Messages postés
2
Date d'inscription
mardi 9 février 2021
Statut
Membre
Dernière intervention
16 février 2021

Bonjour Marvin57700

Si tu veux absolument que les sommes soient en colonne C dans la formule remplace C1 par 1 pour janvier, 2 pour février, etc mais ça t'oblige à changer le numéro du mois pour chacune des 12 lignes ; et attention de bien bloquer les deux zones par $

=SOMMEPROD((MOIS($A$1:$A$40)=1)*($B$1:$B$40))

Ou alors tu mets ailleurs sur la feuille (par exemple Z1 à Z12) les 12 numéros de mois et tu remplaces C1 dans la formule par Z1 et tu fais glisser.

=SOMMEPROD((MOIS($A$1:$A$40)=Z1)*($B$1:$B$40))

As-tu essayé la proposition de TCD donnée par eric (salutations)

Cordialement
Messages postés
3105
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 février 2021
862 >
Messages postés
3105
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 février 2021

RE

Une autre formule avec SOMME.SI.ENS() - voir cet exemple avec cette fonction et les deux autres méthodes mentionnées dans dette discussion

https://www.cjoint.com/c/KBkfYoPc1sk

Cordialement
Messages postés
2
Date d'inscription
mardi 9 février 2021
Statut
Membre
Dernière intervention
16 février 2021
>
Messages postés
3105
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 février 2021

Bonjour,

Désolé pour cette réponse tardive,
Et merci pour la formule, elle a bien fonctionné.


Cordialement,
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021
6 668
Bonjour,

les TCD sont prévus pour ça :
Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=109
et
Grouper champ date : http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=130
eric
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021
6 668
de rien Marvin57700