Supprimer les lignes vides dans Google Sheet.

[Résolu]
Signaler
Messages postés
13
Date d'inscription
vendredi 22 janvier 2021
Statut
Membre
Dernière intervention
27 janvier 2021
-
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
-
Bonjour,

Je souhaiterai supprimer toutes les lignes vides d'un tableau Google Sheet contenant qu'une seule colonne (on peut donc parler d'une liste).

J'ai bien essayé d'utiliser la fonction : "supprimer les espaces vides" dans l'onglet "données", mais cela ne fonctionne pas.
Une fenêtre m'affiche un message que je ne comprends pas : "Espace blanc coupé dans aucune cellule sélectionnée."



Toutes fois Google Sheet est capable de repérer et comptabiliser ces cellules vides :



... pourquoi pas de les supprimer ?

⚠️⚠️ Attention je travaille sur Google Sheet et ne possède pas Excel.
⚠️⚠️ J'ai déjà trouver cette solution sur des tutos Excel mais la solution n'est pas compatible avec Google Sheet.

???????? je vous remercie par avance
A voir également:

3 réponses

Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 786
Bonjour.

De la façon bizarre et très inhabituelle dont tu as créé ta liste, aucune méthode simple n'existe. Il faudrait passer par une macro ...
Messages postés
13
Date d'inscription
vendredi 22 janvier 2021
Statut
Membre
Dernière intervention
27 janvier 2021

Bonjour,

Cette liste est effectivement très spéciale car elle résulte d'un autre tableau bien plus complexe où il y a eu suppression d'un nombre important de doublons, ce qui explique ces nombreuses lignes vides.

Cependant avez-vous une idée concernant le message que m'affiche google sheet lors de l'application de "supprimer les espaces vides" ?
Messages postés
13
Date d'inscription
vendredi 22 janvier 2021
Statut
Membre
Dernière intervention
27 janvier 2021

Quant à créer une macro, c'est probablement une des solutions mais hélas je ne sais absolument pas coder et cela me semble être bien trop compliqué à apprendre pour une telle problématique de base.
Messages postés
2613
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
25 octobre 2021
1 208
Bonjour
une proposition
en B1 formule
=SI(A2<>"";LIGNE();"")
recopier vers le bas

ensuite sélectionner col A et B
trier sur colonne B


Réalisé avec Open office mais cela devrait ressembler à Google Sheet
Messages postés
13
Date d'inscription
vendredi 22 janvier 2021
Statut
Membre
Dernière intervention
27 janvier 2021

C'est génial ça fonctionne !

Merci beaucoup, grâce à vous je vais économiser un temps fou.
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 786
Oui ; très astucieux comme approche ! Bien, yclik ...