PPT, transition auto en mode ZOOM [Résolu]

Signaler
Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021
-
Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021
-
Bonjour,

je sais que cette question a déjà été posée mais ça fait déjà quelques jours que je cherche et teste différentes solutions sans arriver à régler mon problème.

Situation: Dans le cadre d'une présentation Ppts dédiée à des enfants, je veux créer une page "menu" avec différents liens Zoom menant chacun à une diapositive contenant une video. Il est important que le retour à cette diapo (menu) se fasse après chaque vidéo.

Programme: Powerpoint de la suite office 365

Ce que j'ai essayé:
- Cocher "Après" dans la section Passer à la diapo suivante en mettant différentes valeur de temps (0 sec, le temps exacte de la vidéo, 1 sec de plus que la vidéo). Oui j'ai sélectionner l'option pour démarrer la vidéo automatiquement et ça ça marche (thank god!)
- J'ai essayer de faire fonctionner avec le lien Zoom ou seulement la diapositive avec le vidéo pour voir si elle allait passer à la suivante automatiquement; rien.
- J'ai créé un "custom show" pour utiliser l'option "Afficher et revenir" mais une fois encore la présentation fige après la lecture de la video et pour revenir à la diapo Menu, je dois fait un (ou plusieurs) clique. De plus, je perd l'effet de l'animation de la video qui "Zoom in" vers la vidéo.

Autres options:
- Comme les vidéos que j'utilise ont été faits avec Ppts, je pourrais les laisser sous forme de slide dans le même Ppt, les regrouper en "custom show" et tout relié à la diapo Menu, MAIS j'ai l'impression que ça ferait un vraiment gros fichier et je perdrais l'effet "Zoom in".
- En utilisant l'option que je viens de mentionner, je pourrais les reliés à la diapo Menu avec Zoom, mais je ne pense pas que c'est possible de lien un "custom show" avec un Zoom, donc je n'ai pas l'option de "Afficher et revenir". J'ai essayé d'enregistrer (Diaporama > Enregistrer le diaporama > à partir de la diapo actuelle) la section de slide créant le video, mais après ladite sélection, la présentation se poursuit à la diapo suivante plutôt que de revenir à la diapo Menu.

Résumé:
J'AI PLUS AUCUNE IDÉE!!!!!
HELP!
PLEASE!
PAR PITIÉ!

Merci :)

11 réponses

Messages postés
16874
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
10 104
Bonsoir,

A vrai dire tout cela me paraît assez confus.
Et en réalité je ne vois pas où se situe le problème.

Si j'ai compris ton problème :

- Une présentation contenant x diapos contenant chacune une vidéo et rien d'autres
- Insérer un zoom de résumé de façon à visualiser comme on le souhaite une diapo/vidéo et qu'une fois la vidéo terminée, retourner AUTOMATIQUEMENT (sans clic) sur la diapo de zoom.

Pour cela, c'est très simple :
- Choisir démarrage automatique pour chaque vidéo
- Insertion d'une diapo zoom : Insertion => Zoom de résumé et choisir chaque diapo
- Sélection de toutes les diapos vidéo et sous l'onglet Transitions, cocher "Après" (inutile de choisir un temps quelconque).

C'est tout.

Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021

Merci de ta réponse m@rina, je n'avais en effet pas essayé de faire un résumé puisque je bloquait après le premier vidéo. Donc je viens d'essayer, en faisant chaque étape que tu mentionne (et que tu as déjà mentionné pour d'autres avant moi je sais) et j'ai toujours le même problème.

Suite à la vidéo, la présentation fige sur la diapo et je dois cliquer 2 fois pour revenir à la diapo de résumé.

Est-ce que tu as une idée pourquoi?
Messages postés
16874
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
10 104
Bonsoir,

Je viens de faire un petit essai qui fonctionne comme je l'ai dit sans problèmes.

Serait il possible de voir ton fichier (ou un extrait qui ne fonctionne pas) ?
Parce que, comme ça, je ne vois pas ce qui peut bloquer.

TU peux le mettre ici : https://www.cjoint.com/ sans oublier de donner le lien.

m@rina
Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021

Bonjour,

Bon , après plusieurs essais, je n'arrive pas à créer de liens. J'ai essayer des vidéos ou simlement un fichier PPT. Les vidéos étaient sûrement trop gros mais le PPT est de 32 Mb, alors que la limite est de 15Mo (ce qui équivaut à 120 Mb si je ne me trompe pas). Si j'envois des photos ça ne t'aidera sûrement pas à comprendre, je me trompe?
Messages postés
16874
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
10 104
Bonjour,

Fais une copie en ne laissant que quelques diapos. Et tu peux remplacer tes vidéos par de toutes petites vidéos.

A titre d'info, Mo et Mb, c'est la même chose (Mega Octets ou Mega Bytes). Ne pas confondre Byte et Bit. Une taille de fichier se mesure en octets, pas en bits. Un bit c'est tout petit, il faut 8 bits pour faire un octet.

m@rina
Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021

Bonjour m@rina,

donc voici le liens: https://www.cjoint.com/c/KAlqWdpcYH4

le retour semble se faire corrrectement maintenant, le seul bug qui s'entête à persister est le fait qu'après la viédo de droite, plutôt que de revenir à la diapo menu, la présentation se rend d'abord à la diapo qui suit (qui est blanche dans ce cas-ci). Sais-tu pourquoi et comment éviter cela?

Merci,
Antoine
Messages postés
16874
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
10 104
Bonjour,

Si c'est le seul problème qui persiste n'est pas vraiment un problème.
Le zoom se dirige vers une section et affiche toute la section. Or cette deuxième section comporte deux diapos, donc la deuxième diapo (vide) s'affiche. Et comme cette diapo ne comporte pas de transition automatique, le diaporama s'arrête.

m@rina
Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021

Bonjour,

je ne suis pas sûr de bien comprendre. La diapo vide suit bel et bien celle avec le 2eme vidéo, mais le 2eme vidéo suit le 1er et n'est pas inclu lors du liens zoom qui m'envoit au premier vidéo.
Messages postés
16874
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
10 104
Je me répète : chaque zoom de diapo affiche une section entière.
Ta première section est composée d'une seule diapo.
Ta deuxième section est composée de deux diapos dont une vide.

Une fois la section visualisée entièrement, le focus retourne sur la diapo de zoom, que ce soit grâce à une transition automatique, ou via un clic.

Or la dernière diapo de la deuxième section n'a pas de transition automatique, il ne se passe donc rien tant qu'on n'a pas cliqué.
Si, sur cette diapo vide, tu mets une transition automatique, la vidéo s'affichera, puis la diapo vide, et enfin retour à la diapo de zoom.

m@rina
Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021

Merci de clarifier la source du problème, mais ça ne m 'apporte pas vraiment de solution. J'ai regardé pour gérer les diapositives dans une section et la seule solution que j 'ai trouvé c'est d'en créer une autre pour y mettre les diapo qui n'ont pas leur place dans une section.

Est-ce que tu sais si il y a un moyen de simplement sortir une diapo hors sections ou est-ce qu'une fois qu'on commence à créer des sections, il faut que chaque diapo en fasse partie d'une?

Aussi, lorsque je débarre la présentation, les diapo focntionnent et reviennent à la diapo de résumé lors de leur première activation, mais si je clique une 2eme fois, la vidéo ne démarre plus seule et lorsque je clique pour démarrer, elle revient aussitôt à la diapo de résumé sans lire ladite vidéo. Tu sais pourquoi et comment assurer que ça fonctionne correctement même à répétition?
Messages postés
16874
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
10 104
Bonjour,

Pour les sections : à partir du moment où il y a une section, toutes les diapos qui ne seront pas dans cette section le seront forcément dans une autre ou plusieurs autres.
A vrai dire je ne vois pas vraiment où est le problème. Après il s'agit de savoir à quel moment on va activer ces diapos, et de quelle manière.

Pour ce qui est des vidéos : le démarrage d'une vidéo dans PowerPoint est considérée comme une animation. Et une animation ne fonctionne effectivement qu'une seule fois.
Pour pallier ce problème, il y a deux solutions :
- soit utiliser les diaporamas personnalisés,
- soit une macro.

La solution des diaporamas personnalisés que tu as évoquée, je crois, dans le premier post, est qu'ils ne sont pas compatibles avec un zoom de résumé. Ce qui revient à dire qu'il faudrait du manuel : insérer des copies des slides et pour chaque slide faire une transition zoom par exemple.

La solution macro est sans doute plus rapide. Voici une macro événementielle (ne pas changer son nom) qui va se déclencher sur chaque diapo et redémarrer les animations, et donc fonctionner sur toutes les diapos avec vidéo.

Sub OnSlideShowPageChange(ByVal SSW As SlideShowWindow)
Dim diapo
diapo = SSW.View.CurrentShowPosition
SlideShowWindows(1).View.GotoSlide diapo, True
End Sub


m@rina
Messages postés
8
Date d'inscription
mercredi 6 janvier 2021
Statut
Membre
Dernière intervention
12 janvier 2021

Cool!

Merci pour ça!